Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » поиск и суммирования по нужным значениям
поиск и суммирования по нужным значениям
plasДата: Воскресенье, 15.02.2009, 22:08 | Сообщение # 1
Группа: Пользователи
Сообщений: 4
Статус: Offline
Здравствуйте!
в файле желтым обозначил что нужно искать.
К примеру в А 10 раз повторяется Тел-р. монитор двд-плейер
мне нужно что бы каждый повтор складывался
к примеру если в А2 есть текст Тел-р. монитор или dvd-плейер то с B2 брать значение и вставлять в ячейку (кол-во)
потом в А3 есть текст Тел-р. , монитор или dvd-плейер то с B3 брать значение и суммировать в ячейку с кол-ом.

если проще нужно
знать сколько тел-р. двд-плейер монитор было продано кол-во ,на какую сумму и какая прибыль.
в 3 строки все количество нужного товара , общая сумма, общая прибыль.

Прикрепления: test.xls(39.5 Kb)
 
sizopДата: Понедельник, 16.02.2009, 08:11 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
plas, примерно так
Прикрепления: 1196208.xls(39.5 Kb)
 
plasДата: Понедельник, 16.02.2009, 09:13 | Сообщение # 3
Группа: Пользователи
Сообщений: 4
Статус: Offline
Ну да спасибо примерно так,только я думал можно както искат ьне 1 а сраз у несколько значений(я сгруппирую и все решится)
добавил *Тел-р* чтобы по всему тексту искал.огромное спасибо,оказывается ненадо было велосипед выдумывать.

п.с. а что за онлайн рассылка через icq?
помощь онлайн по excel или что-то другое,ненашел описания.

 
AuthorДата: Понедельник, 16.02.2009, 11:35 | Сообщение # 4
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Рассылки через icq нет, но есть онлайн помощь, но она платная


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
plasДата: Вторник, 17.02.2009, 09:54 | Сообщение # 5
Группа: Пользователи
Сообщений: 4
Статус: Offline
ну я какбы и хотел это узнать. а ссылка на номер аси за смс будет обновленна.файла там нет smile
 
ptizzzaДата: Среда, 30.09.2009, 13:53 | Сообщение # 6
Группа: Пользователи
Сообщений: 9
Статус: Offline
plas,
Спасибо за тему! У меня была такая же проблемка, теперь все заработало!
sizop,
Спасибо за разрешение проблемы! Молодцы, что помогаете людям!!!
А можно сделать так, чтобы формула нашла в колонке "Тел-р" и добавила 1, нашла еще раз "Тел-р" еще добавила 1, получили уже 2? Если нет колонки с количеством?


Сообщение отредактировал ptizzza - Среда, 30.09.2009, 14:03
 
DV68Дата: Среда, 30.09.2009, 14:45 | Сообщение # 7
Группа: Модераторы
Сообщений: 648
Статус: Offline
Тогда:
=СЧЁТЕСЛИ(A$2:A$65536;"Тел-р*")
 
ptizzzaДата: Среда, 30.09.2009, 15:00 | Сообщение # 8
Группа: Пользователи
Сообщений: 9
Статус: Offline
DIM5955, Спасибо!
 
ptizzzaДата: Среда, 30.09.2009, 17:41 | Сообщение # 9
Группа: Пользователи
Сообщений: 9
Статус: Offline
А если таких диапазонов несколько, например 6 столбцов?
 
vladДата: Среда, 30.09.2009, 18:06 | Сообщение # 10
Группа: Модераторы
Сообщений: 720
Статус: Offline
Quote (ptizzza)
А если таких диапазонов несколько, например 6 столбцов?

Тогда включаем все 6-ь столбцов в диапазон . Единственное требование диапазоны должны быть смежными.
Хотя если искомые значения встречаются только в этих 6-и полях , то можно выбрать для просчета вообще весь диапазон.


Сообщение отредактировал vlad - Среда, 30.09.2009, 18:07
 
ptizzzaДата: Среда, 30.09.2009, 18:32 | Сообщение # 11
Группа: Пользователи
Сообщений: 9
Статус: Offline
=СУММ(СЧЁТЕСЛИ(ПН;1);СЧЁТЕСЛИ(ВТ;1);СЧЁТЕСЛИ(СР;1);СЧЁТЕСЛИ(ЧТ;1);СЧЁТЕСЛИ(ПТ;1);СЧЁТЕСЛИ(СБ;1))
Я сделал это вот так! ПН,ВТ...СБ - это стандартные диапазоны, 1 - искомое число.
Теперь у меня другой вопрос. У меня очень много искомых чисем, под 100. Как перекопировать ячейку с формулой, чтобы критерий(искомое чило) увеличиволось на 1? Помогите, я уже задолбался думать.
 
DV68Дата: Среда, 30.09.2009, 18:34 | Сообщение # 12
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если столбцы не смежные, суммируем:
=СЧЁТЕСЛИ(A:A;"*Тел-р*")+СЧЁТЕСЛИ(С:С;"*Тел-р*"), если подряд, то как и сказал vlad:
=СЧЁТЕСЛИ(A:F;"*Тел-р*")
 
DV68Дата: Среда, 30.09.2009, 18:37 | Сообщение # 13
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (ptizzza)
Теперь у меня другой вопрос. У меня очень много искомых чисем, под 100. Как перекопировать ячейку с формулой, чтобы критерий(искомое чило) увеличиволось на 1? Помогите, я уже задолбался думать.

хотелось бы небольшой, но максимально приближенный к реальности пример, для лучшего понимания.
 
ptizzzaДата: Среда, 30.09.2009, 18:37 | Сообщение # 14
Группа: Пользователи
Сообщений: 9
Статус: Offline
Я вот с этим файликом мудохаюсь.
И что такое смежные диапазоны???
Прикрепления: 2651098.xls(256.5 Kb)
 
DV68Дата: Среда, 30.09.2009, 18:41 | Сообщение # 15
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если формулы растягиваются вниз, то вместо значения ставите ссылку на ячейку в той же строке, в этой ячейке прописываете это значение, например 1. Затем ячейку со значением растягиваем вниз, чтобы получился список 1,2,3..... Соответственно потом растягиваем вниз формулу. Примерно так.
 
ptizzzaДата: Среда, 30.09.2009, 18:42 | Сообщение # 16
Группа: Пользователи
Сообщений: 9
Статус: Offline
=СУММ(СЧЁТЕСЛИ(ПН;AK19);СЧЁТЕСЛИ(ВТ;AK19);СЧЁТЕСЛИ(СР;AK19);СЧЁТЕСЛИ(ЧТ;AK19);СЧЁТЕСЛИ(ПТ;AK19);СЧЁТЕСЛИ(СБ;AK19))
Сделал!!! Вместо цифр загнал ячейки с цифрами!!! Ура!!!
Спасибо всем за помощь!!!
 
ptizzzaДата: Среда, 30.09.2009, 18:43 | Сообщение # 17
Группа: Пользователи
Сообщений: 9
Статус: Offline
DIM5955, спасибо,я не допер сразу, мозги уже не варят!!! Спасибо еще раз!!!
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » поиск и суммирования по нужным значениям
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz