Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » сумма разных значений
сумма разных значений
BiaktrisaДата: Вторник, 21.12.2010, 18:48 | Сообщение # 1
Группа: Проверенные
Сообщений: 32
Статус: Offline
задача такая допустим в столбике А расположены значения (номера накладных)
12
13
14
14
14
15
16
16
17
18
18
18

сумма 7
надо посчитать сколько всего накладных тоесть повторы не учитывать

 
Serge_007Дата: Вторник, 21.12.2010, 22:15 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Формула массива:
Code
=СЧЁТ(ЕСЛИ(ПОИСКПОЗ(A1:A12;A1:A12;0)=СТРОКА(A1:A12);СТРОКА(A1:A12)))

или
Code
=СУММПРОИЗВ(--(ПОИСКПОЗ(A1:A12;A1:A12;0)=СТРОКА(A1:A12)))

ЗЫ На будущее: Наличие файла ускоряет процесс получения ответа.

Прикрепления: Biaktrisa.xls(24Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
DV68Дата: Среда, 22.12.2010, 02:12 | Сообщение # 3
Группа: Модераторы
Сообщений: 648
Статус: Offline
Еще варианты "немассивных":
Code
=СЧЁТ(1/(ЧАСТОТА(A1:A12;A1:A12)>0))

Code
=СУММ(ЕСЛИ(ЧАСТОТА(A1:A12;A1:A12)>0;1))

Code
=СУММ(МУМНОЖ(--(ЧАСТОТА(A1:A12;A1:A12)>0);1))
Прикрепления: Biaktrisa2.xls(18Kb)
 
BiaktrisaДата: Среда, 22.12.2010, 13:56 | Сообщение # 4
Группа: Проверенные
Сообщений: 32
Статус: Offline
спасибо огромное.
 
BiaktrisaДата: Среда, 22.12.2010, 14:53 | Сообщение # 5
Группа: Проверенные
Сообщений: 32
Статус: Offline
biglaugh
 
TyronДата: Среда, 22.12.2010, 19:39 | Сообщение # 6
Группа: Пользователи
Сообщений: 3
Статус: Offline
Есть проблема с формулами.
Имеем установленную работникам премию. Из за уменьшения некоторым, появляется экономия премии. Вот эту экономию и нужно автоматически распределить между работниками, получающими премию в размере 100%
Трудно вот так описать словами, поэтому подробно изложил в прикрепленном файле
Прикрепления: 8705254.xls(18Kb)
 
Serge_007Дата: Среда, 22.12.2010, 21:53 | Сообщение # 7
Группа: Проверенные
Сообщений: 468
Статус: Offline
.
Прикрепления: Tyron.xls(28Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390


Сообщение отредактировал Serge_007 - Среда, 22.12.2010, 21:54
 
TyronДата: Среда, 22.12.2010, 21:59 | Сообщение # 8
Группа: Пользователи
Сообщений: 3
Статус: Offline
Огромное спасибо Serge_007
Все правильно и главное оперативно
 
Serge_007Дата: Среда, 22.12.2010, 22:26 | Сообщение # 9
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Tyron)
Все правильно и главное оперативно

А я думал что главное правильно ;)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
TyronДата: Среда, 22.12.2010, 22:32 | Сообщение # 10
Группа: Пользователи
Сообщений: 3
Статус: Offline
Оперативность тоже очень важна. Премию уже завтра выплачивать
 
Serge_007Дата: Среда, 22.12.2010, 23:51 | Сообщение # 11
Группа: Проверенные
Сообщений: 468
Статус: Offline
Позволю себе небольшой оффтоп (если неправ - модераторы удалят).
Quote (Tyron)
Оперативность тоже очень важна. Премию уже завтра выплачивать

Биатлон как секс - если не попал - то скорость не спасёт :)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » сумма разных значений
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz