Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » проблема с БД (проблема с БД)
проблема с БД
BiaktrisaДата: Воскресенье, 21.11.2010, 13:24 | Сообщение # 1
Группа: Проверенные
Сообщений: 32
Статус: Offline
не пинайте сразу я еще ток учусь фишкам екселя
нужна помощь задача в файле
Прикрепления: 0332387.xls(7Kb)


Сообщение отредактировал Biaktrisa - Воскресенье, 21.11.2010, 13:25
 
DV68Дата: Воскресенье, 21.11.2010, 16:30 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
В справке Excel присмотритесь к функции ВПР,

по задаче:
=ВПР(C5;база!$A$2:$B$4;2;0)



Сообщение отредактировал DIM5955 - Воскресенье, 21.11.2010, 16:31
 
BiaktrisaДата: Воскресенье, 21.11.2010, 16:45 | Сообщение # 3
Группа: Проверенные
Сообщений: 32
Статус: Offline
получается только при одном условии если вводить ай ди попорядку в соответствии с базой а надо что бы вводишь любое айди из базы и она искала если есть такое ай ди в базе то подставляла значение
 
DV68Дата: Воскресенье, 21.11.2010, 17:34 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Поподробнее, что не так(скопировал формулу с форума и вставил в файл):
Прикрепления: 0332387_gde.xls(23Kb)
 
BiaktrisaДата: Воскресенье, 21.11.2010, 18:00 | Сообщение # 5
Группа: Проверенные
Сообщений: 32
Статус: Offline
попробую по другому объяснить на живом примере
спасибо кто уделяет мне внимание
Прикрепления: _01.zip(314Kb)
 
DV68Дата: Воскресенье, 21.11.2010, 18:45 | Сообщение # 6
Группа: Модераторы
Сообщений: 648
Статус: Offline
Вы про ВПР читали?
 
BiaktrisaДата: Воскресенье, 21.11.2010, 18:49 | Сообщение # 7
Группа: Проверенные
Сообщений: 32
Статус: Offline
да не получается ни хрена с ВПР
он не ищет в базе айди а просто подставляет значение если по порядку вводить айди как в базе
 
DV68Дата: Воскресенье, 21.11.2010, 18:54 | Сообщение # 8
Группа: Модераторы
Сообщений: 648
Статус: Offline
покажите пример, как у Вас получается.
У меня все нормально:
Прикрепления: _01.rar(284Kb)
 
DV68Дата: Воскресенье, 21.11.2010, 19:02 | Сообщение # 9
Группа: Модераторы
Сообщений: 648
Статус: Offline
Я думаю у Вас проблема с тем, что Вы не знаете, что такое относительные и абсолютные ссылки(значки $ в формуле). Почитайте про них обязательно.
 
DV68Дата: Воскресенье, 21.11.2010, 19:13 | Сообщение # 10
Группа: Модераторы
Сообщений: 648
Статус: Offline
И еще (смотрел на соседнем форуме Ваш файл, он в ОО сделан), там ВПР представлена как VLOOKUP:
Code
=VLOOKUP(C5;$база.$A$2:$B$4;2;0)
 
BiaktrisaДата: Воскресенье, 21.11.2010, 19:17 | Сообщение # 11
Группа: Проверенные
Сообщений: 32
Статус: Offline
Dim в решении которое ты выслал в файле сделано все правильно а вот с этим =ВПР(C5;база!$A$2:$B$4;2;0) у меня естественно не получалось .
спасибо огромное. up


Сообщение отредактировал Biaktrisa - Воскресенье, 21.11.2010, 19:18
 
BiaktrisaДата: Четверг, 09.12.2010, 18:11 | Сообщение # 12
Группа: Проверенные
Сообщений: 32
Статус: Offline
по проблемме которая описаны выше мне подошла формула
=IF(D7="";"";IF(ISNA(VLOOKUP(D7;$baza.$A$2:$B$15687;2;0));"нет такого";VLOOKUP(D7;$baza.$A$2:$B$15687;2;0)))

можно как нить усовершенствовать теперь что бы не только закладка "baza" была но и скажем "baza1" ,"baza2" ,"baza3"
спасибище огромное

 
DV68Дата: Четверг, 09.12.2010, 18:20 | Сообщение # 13
Группа: Модераторы
Сообщений: 648
Статус: Offline
Пример ускорил бы решение. Только не нужен большой пример. Для понимания можно и несколько строк баз.
 
BiaktrisaДата: Четверг, 09.12.2010, 18:53 | Сообщение # 14
Группа: Проверенные
Сообщений: 32
Статус: Offline
прикрипил пример там же задание , спасибо
Прикрепления: __v2.0.xls(179Kb)
 
DV68Дата: Четверг, 09.12.2010, 19:09 | Сообщение # 15
Группа: Модераторы
Сообщений: 648
Статус: Offline
Так как много данных, то формулы массива подвесят файл.
Поэтому с двумя доп столбцами:
Прикрепления: _v2.0_otv.rar(47Kb)
 
BiaktrisaДата: Четверг, 09.12.2010, 19:34 | Сообщение # 16
Группа: Проверенные
Сообщений: 32
Статус: Offline
спс хоть такое решение
 
DV68Дата: Четверг, 09.12.2010, 19:50 | Сообщение # 17
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (Biaktrisa)
спс хоть такое решение

Если найдете лучше (в том числе и не более ресурсоемкое), то покажите (пригодится для самообразования)
 
vladДата: Суббота, 11.12.2010, 00:16 | Сообщение # 18
Группа: Модераторы
Сообщений: 720
Статус: Offline
Вот вариант без использования доп столбцов. bw
Прикрепления: variant.xls(182Kb)
 
DV68Дата: Среда, 15.12.2010, 17:04 | Сообщение # 19
Группа: Модераторы
Сообщений: 648
Статус: Offline
vlad, молодец!
А я почему-то сразу отказался от решения одной формулой, видимо из-за этого:
Quote (Biaktrisa)
не только закладка "baza" была но и скажем "baza1" ,"baza2" ,"baza3"
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » проблема с БД (проблема с БД)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz