Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 03.07.09 (Заполнение списков одинаковыми значениями)
03.07.09
AuthorДата: Пятница, 17.07.2009, 21:01 | Сообщение # 1
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline


Заполнение списков одинаковыми значениями

Название: Применение формулы для формирования списка (например, после сводной таблицы)

Допустим, у Вас есть спиок, вида:



Северное направление









Восточное направление













Южное направление







, а Вам необходимо сформировать список:



Северное направление

Северное направление

Северное направление

Северное направление

Северное направление

Восточное направление

Восточное направление

Восточное направление

Восточное направление

Восточное направление

Восточное направление

Восточное направление

Южное направление

Южное направление

Южное направление

Южное направление



Если первоначальные данные начинаются с ячейки B2, то для того, чтобы получить конечный список (заполнить одинаковыми значениями), поместите, например, в ячейку C2 формулу =ЕСЛИ(B2="";C1;B2) и растяните ее вниз до C17.

При всей своей простоте, эта формула незаменима в очень многих случаях, когда требуется создать список, заполненный всеми значениями до нового значения.

Авторы рассылки не раз наблюдали, как некоторые пользователи для решения этой задачи тратили многие минуты, и, даже, иногда, часы "щелкая" по каждому слову (этот способ работает, если рядом от текущего столбца справа или слева имеется столбец заполненный формулами или значениеями), либо же растягивая вручную каждое значение до того момента, пока не встретиться новое значение.

Заполнение же с помощью приведенной формулы универсально.

Еще раз формула:

=ЕСЛИ(B2="";C1;B2)

Замечания к формуле:

Не перестарайтесь и не растяните формулу на большее число значений, чем у Вас в списке, иногда это может привести к неккоректностям при дальнейших подсчетах. Приведенная формула служит для заполнения по срокам, если же ее немного переделать, то можно заполнять зачения и по столбцам.

Сочетание клавиш в Excel скрытие столбцов

Как скрыть столбцы с помощью сочетания клавишь в Excel

Часто бывает необходимо скрывать столбцы. Это, конечно, можно делать через контекстное меню появляющееся после выделения необходимого столбца или столбцов и выбрав пункт "Скрыть", но...

То же самое можно делать и на клавиатуре.

Итак, сочетание: Ctrl+) /закрывающая скобка/.

Как работает это сочетание: 1) если не выделено ничего и Вы стоите в какой-либо ячейке на листе, то после применения этого сочетания текущий столбец будет скрыт; 2) если вы выделили любой прямоугольный диапазон (допускается даже выделение несмежных диапазонов), либо столбцы целиком, то будут скрыты все столбцы ячейки которых были выделены.

Ссылки на книги об Excel

Книги по Excel доступны на сайте рассылки

Теперь на сайте рассылки будут выкладываться книги, интересные статьи, рефераты, различные электронные курсы по Excel. Книги в основном будут выкладываться в форматах pdf, djvu.


Уже доступны книги:

Бондаренко С. и Бондаренко М. Excel 2003. Популярный самоучитель

Фрай К. Хитрости Excel

Знаете ли Вы, что в Excel...


…если Вы вручную скрыли строки, затем выделили диапазон, скопировали, и вставили, то вставятся не только значения из видимых строк, но и значения из невидимых строк?

Что же делать, если необходимо скопировать и вставить только видимые значения строк?

Выход есть: 1) выделите необходимый диапазон; 2) Правка-Перейти-Выделить и поставьте "точку" напротив "только видимые ячейки".

Теперь Вы можете смело копировать и вставлять. Будут вставлены значения только видимых ячеек!



Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 03.07.09 (Заполнение списков одинаковыми значениями)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz