Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 27.02.08 (суммирование по нескольким критериям)
27.02.08
sizopДата: Вторник, 20.01.2009, 20:01 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline

Формулы Excel: суммирование по нескольким критериям

Название: Возможности функции СУММПРОИЗВ() для суммирования по нескольким критериям

Допустим, у нас есть таблица, в которой хранятся такие данные: дата, поставщик, товар, сумма. Из практики работы Вы наверняка сталкивались с ситуацией, когда необходимо было просуммировать не только на какую сумму поставлено товара от определенного поставщика, но и какого именно товара. Как известно, функция СУММЕСЛИ() позволяет нам получить сумму по определенному критерию, но только по одному. Для того, чтобы получить сумму сразу по нескольким критериям, она не подходит. Для этих целей предлагаем Вам пользоваться функцией СУММПРОИЗВ().


В приведенной ниже формуле в диапазоне B2:B51 находятся названия поставщиков, в диапазоне C2:C51 – названия товаров, в D2:D51 – сумма поставки.



=СУММПРОИЗВ(--(B2:B51=H4);--(C2:C51=H5);D2:D51)

англ. вариант

=SUMPRODUCT(--(B2:B51=H4);--(C2:C51=H5);D2:D51)

Эта формула позволяет узнать, на какую сумму было получено товаров с именем указанным в ячейке H5 от поставщика имя которого указано в ячейке H4.

Также функцию СУММПРОИЗВ() можно использовать и в других случаях.


Файл-пример можно скачать по ссылке

Сочетание клавиш Excel - диалоговое окно "Формат ячеек"

Комбинация клавиш Excel для вызова окна Формат ячеек

Для того, чтобы в Excel вызвать диалоговое окно "Формат ячеек" достаточно одновременно нажать клавиши Ctrl и 1 (единица в верхнем ряду клавиатуры).

В окне "Формат ячеек" Вы сможете не только установить необходимый формат ячейки, но и задать необходимое выравнивание, установить формат шрифта, границы, вид ячейки, а также защиту.

Совет по использованию Excel


Чтобы выделить все пустые ячейки (в выделенном диапазоне или на листе) проделайте следующее.

При включенной русской раскладке клавиатуры зажмите клавишу Alt и последовательно нажмите следующие русские буквы: "п", "п", "в", "й" и нажмите клавишу "Enter" (Ввод). Совет подходит только для пользователей русской версии Excel. Вы можете проделать то же самое и с помощью мышки.

Полезная ссылка Excel


Как импортировать нужные сведения c веб-страниц в Excel



Адрес excel-ok@yandex.ru ждет твой экселевский файл. Мы поможем тебе разобраться.


 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 27.02.08 (суммирование по нескольким критериям)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz