Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 11.03.07 (пример создания формулы с несколькими проверками)
11.03.07
sizopДата: Вторник, 20.01.2009, 19:51 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline

Формулы Excel - пример создания формулы с несколькими проверками

Название: Определение количества заданного символа в ячейке содержащей текст


=ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;B1;""))


(базовая формула)

Эта формула позволяет определить сколько раз символ, который находится в ячейке B1 повторяется (входит) в ячейку содержащую текст (в нашем случае это ячейка A1).

На примере этой формулы покажем, как создаются более сложные формулы, в которых присутствуют встроенные проверки.

В нашем случае следует проверить:

1) содержится ли в ячейке A1 текст (а не число или дата, или время и т.д.);

2) введен ли в ячейку B1 только 1 символ (если несколько, то первоначальная формула даст некорретный результат).

Последовательно будем добавлять различные усовия/проверки используя функцию ЕСЛИ.

Вот реализация первой проверки:


=ЕСЛИ(ТИП(A1)=2;ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;B1;""));"в ячейке не текст")

То есть мы добавили 1 условие, которое реализовано с помощью логической функции ЕСЛИ и функции проверки свойств и значений ТИП. В случае выполнения условия ТИП(A1)=2, означающему, что ячейка A1 - текстовая, мы переходим к расчету (базовая формула), в случае, если условие не выполняется, то появится сообщение "в ячейке не текст".

Следующее условие, выполнение которого нам нужно проверить: в ячейке B1 - один символ или больше? Если в ней только один символ - проводим вычисления, если больше - выдаем предупреждающее сообщение.

Действуем аналогично, то есть используем еще одну функцию ЕСЛИ, а также воспользуемся функцией ДЛСТР, которая определит сколько символов в нужной нам ячейке. Получаем такую формулу:


=ЕСЛИ(ДЛСТР(B1)<>1;"символ не введен, либо количество символов больше одного";ЕСЛИ(ТИП(A1)=2;ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;B1;""));"в ячейке не текст"))

Как видите, мы просто добавили еще одно условие, а также воспользовались формулой полученной на предыдущем этапе.

Сочетание клавиш Excel - быстрое создание диаграммы

Горячие клавиши Excel - мгновенное создание диаграммы

Для того, чтобы быстро построить диаграмму используйте сочетание клавишь Alt+F1 (одновременное нажатие).

Последовательность действий: выделяем таблицу, на базе значений которой должна быть построена диаграмма, и нажимаем Alt+F1. После этого на отдельном листе будет построена диаграмма (и этот лист станет активным - то есть Вы "перенесетесь" на этот лист). Автоматически этому листу будет присвоено имя "Диаграмма1" (в русской версии Excel). Если необходимо, Вы всегда сможете переименовать его.

Недостатки этого способа создания диаграмм: автоматически Вы можете построить только 1 вид диаграмм, который называется обычная гисторграмма (обычная гистограмма отображает значения различных категорий). Конечно же, Вы всегда можете изменить/настроить любые необходимые Вам параметры или тип диаграммы.

Совет по использованию Excel

Наверняка Вы сталкивались с такой ситуацией: данные, которые Вам нужны для дальнейшей работы находятся "в столбик", а Вам необходимо, чтобы они были "в строку" (или наоборот). Перетаскивать ячейки по одной, а тем более перенабирать данные, мягко выражаясь, не эффективно. Это неоправданные затраты Вашего времени, сил, внимания и нервов. Создатели и разработчики Excel позаботились о том, чтобы это можно было сделать "легко и просто". Покажем решение этой проблемы на примере.

Допустим, у Вас есть информация расположенная в столбце (пусть это будут названия клавишь):

Insert

Delete

Home

End

Page Up

Page Down

стрелка влево

стрелка вправо

стрелка вверх

стрелка вниз

пробел

Tab

Enter

BackSpace

F1

F2

F3

F4

.. а Вам необходимо, чтобы она располагалась в одной строке...

...вот решение этой проблемы:

1. выделяем все необходимые нам ячейки (в данном случае их восемнадцать)

2. нажимаем клавиши Ctrl+Ins (или кнопочку "копировать" на панели инструментов)

3. перемещаемся в то место листа куда необходимо вставить значения

4. нажимаем правую кнопку мыши и из появившегося контекстного меню выбираем "Специальная вставка"

5. в появившемся окошке ставим "птичку" напротив слова "транспонировать" и нажимаем "Ок".

Получаем запланированный результат.

Не правда ли удобно? smile

Хочется обратить Ваше внимание на окошко "Специальная вставка".

В нем, кроме описанной, присутствует также и масса других возможностей.

Знаете ли Вы что Excel...


... "помнит" последние 10 введенных Вами функций?...

Как и где это можно увидеть: Вставка-Функция (категория "10 недавно использовавшихся").

Для любопытных: 10 недавно использовавшихся функций автора рассылки

 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 11.03.07 (пример создания формулы с несколькими проверками)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz