Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 05.03.07 (Определение количества заданного символа в ячейке содержащей)
05.03.07
sizopДата: Вторник, 20.01.2009, 19:50 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline

Формулы Excel - пример создания формулы с несколькими проверками

Название: Определение количества заданного символа в ячейке содержащей текст


=ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;B1;""))

Эта формула позволяет определить сколько раз символ, который находится в ячейке B1 повторяется (входит) в ячейку содержащую текст (в нашем случае это ячейка A1).

На примере этой формулы покажем, как создаются более сложные формулы, в которых присутствуют встроенные проверки.

В нашем случае следует проверить:

1) содержится ли в ячейке A1 текст (а не число или дата, или время и т.д.);

2) введен ли в ячейку B1 только 1 символ (если несколько, то первоначальная формула даст некорретный результат).

Последовательно будем добавлять различные усовия (проверки) с помощью функции ЕСЛИ.

Вот реализация этой проверки:

=ЕСЛИ(ТИП(A1)=2;ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;B1;""));"в ячейке не текст")

То есть мы добавили 1 условие, которое реализовану с помощью логической функции ЕСЛИ и функции проверки свойств и значений ТИП. В случае выполнения условия, то есть ТИП(A1)=2, что означает, что ячейка A1 - текстовая, мы переходим к расчету, то есть к базовой формуле, в случае, если условия не выполняется, то появится сообщение "в ячейке не текст".

Следующая условие, выполнение которого нам нужно проверить: в ячейке B1 - 1 символ или больше? Если 1 - проводим вычисления, если больше - выдаем предупреждающее сообщение.

Действуем аналогично, то есть используем еще одну функцию ЕСЛИ, а также воспользуемся функцией ДЛСТР, которая определит сколько символов в нужной нам ячейке. Получаем такую формулу:

=ЕСЛИ(ДЛСТР(B1)<>1;"символ не введен, либо количество символов больше одного";ЕСЛИ(ТИП(A1)=2;ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;B1;""));"в ячейке не текст"))

Как видите, мы просто добавили еще одно условие, а также воспользовались формулой полученной на 2-м этапе.

Продолжаем описание сочетаний клавиш Excel позволяющих быстро заполнять ячейки значениями или формулами

Сочетание клавиш Excel - заполнение правой ячейки

По аналогии с уже описанным сочетанием клавиш позволяющем заполнит нижнюю ячейку, существует и сочетание клавишь позволяющее заполнить правую ячейку. Для того, чтобы заполнить правую ячейку одновременно нажмите Ctrl+R. Это сочетание работает как для значений (констант), так и для формул.

Совет по использованию Excel

В прошлом выпуске рассылки мы говорили о строке состояния. Сейчас мы хотим предложить Вам оригинальный способ ее использования. Речь идет о возможности сравнения больших (любых) чисел. Например, Вам, по ходу работы необходимо определить равны два числа. Если эти числа не более чем четырех-пятизначные и у Вас хорошая память, то сделать это довольно легко. Однако, если числа 10-12 и более "значные", то это уже намного сложнее. Особенно, если эти числа находятся, например, в ячейках A10 и AA110 (то есть в ячейках, значения которых невозможно увидеть сразу на одном экране без скрытия строк и/или столбцов).

Как сравнить их? Как узнать, равны ли они?

Довольно просто (вот порядок действий): станьте в ячейку, содержащую первое число, а затем, удерживая клавишу Ctrl (помните, это было в самом первом выпуске ), станьте во вторую ячейку (то есть, Вы как бы выделяете эти две ячейки). После этого, щелкнув на строке состояния правой кнопкой мыши, выберите из списка "Среднее". Если получившееся среднее будет равно значению в любой видимой Вам ячейке, то числа равны.

Важное замечание: в строке состояния значение показывается в том формате, который имеет последняя из выбранных ячеек. Поэтому, если формат ячеек, в которых находятся сравниваемые числа, отличается, Вы можете увидеть некорректный результат. Поэкспериментируйте с этим советом, и Вы сами убедитесь в этом.

Знаете ли Вы что в Excel


допустимо вводить несколько строк в одну ячейку?

Как это сделать?

Для того, чтобы ввести текст, состоящий из нескольких строк в одну ячейку (для тех, кто читает нашу рассылку впервые, напомним, что мы говорим о программе Excel) в конце первой необходимой Вам строки нажмите Alt+Enter (одновременное нажатие клавиш) и Вы перейдете на следующую строку. Соответственно для ввода следующих строка снова нажимайте Alt+Enter.

 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 05.03.07 (Определение количества заданного символа в ячейке содержащей)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz