Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 05.02.07 (Игнорирование нулевых значений)
05.02.07
sizopДата: Вторник, 20.01.2009, 19:49 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline

Сегодняшняя готовая формула Excel

Название: Игнорирование нулевых значений


=ЕСЛИ(МИН(A2:A21)=0;НАИМЕНЬШИЙ(A2: A21;2);МИН(A2: A21))

Эта формула возвращает минимальное значение для диапазона A2:A21, при этом, если в диапазоне A2:A21 встречаются 0 (нулевые значения), то определяется минимальное значение без учета нулей.

Продолжаем описание сочетаний клавиш Excel позволяющих быстро заполнять ячейки значениями или формулами

Сочетание клавиш Excel - заполнение правой ячейки

По аналогии с уже описанным сочетанием клавиш позволяющем заполнит нижнюю ячейку, существует и сочетание клавишь позволяющее заполнить правую ячейку. Для того, чтобы заполнить правую ячейку одновременно нажмите Ctrl+R. Это сочетание работает как для значений (констант), так и для формул.

Совет по использованию Excel

В прошлом выпуске рассылки мы говорили о строке состояния. Сейчас мы хотим предложить Вам оригинальный способ ее использования. Речь идет о возможности сравнения больших (любых) чисел. Например, Вам, по ходу работы необходимо определить равны два числа. Если эти числа не более чем четырех-пятизначные и у Вас хорошая память, то сделать это довольно легко. Однако, если числа 10-12 и более "значные", то это уже намного сложнее. Особенно, если эти числа находятся, например, в ячейках A10 и AA110 (то есть в ячейках, значения которых невозможно увидеть сразу на одном экране без скрытия строк и/или столбцов).

Как сравнить их? Как узнать, равны ли они?

Довольно просто (вот порядок действий): станьте в ячейку, содержащую первое число, а затем, удерживая клавишу Ctrl (помните, это было в самом первом выпуске ), станьте во вторую ячейку (то есть, Вы как бы выделяете эти две ячейки). После этого, щелкнув на строке состояния правой кнопкой мыши, выберите из списка "Среднее". Если получившееся среднее будет равно значению в любой видимой Вам ячейке, то числа равны.

Важное замечание: в строке состояния значение показывается в том формате, который имеет последняя из выбранных ячеек. Поэтому, если формат ячеек, в которых находятся сравниваемые числа, отличается, Вы можете увидеть некорректный результат. Поэкспериментируйте с этим советом, и Вы сами убедитесь в этом.

Знаете ли Вы что в Excel


допустимо вводить несколько строк в одну ячейку?

Как это сделать?

Для того, чтобы ввести текст, состоящий из нескольких строк в одну ячейку (для тех, кто читает нашу рассылку впервые, напомним, что мы говорим о программе Excel) в конце первой необходимой Вам строки нажмите Alt+Enter (одновременное нажатие клавиш) и Вы перейдете на следующую строку. Соответственно для ввода следующих строка снова нажимайте Alt+Enter.

 
AuthorДата: Среда, 21.01.2009, 12:26 | Сообщение # 2
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Комментарий к формуле =ЕСЛИ(МИН(A2:A21)=0;НАИМЕНЬШИЙ(A2: A21;2);МИН(A2: A21)):
формула корректно отработает только в том случае, если в диапазоне A2: A21 только 1 нулевое значение.
Если же необходимо определить минимум для диапазона в котором неизвестно сколько нулевых значений, то следует воспользоваться следующими формулами:
1 вариант
=ЕСЛИ(МИН(A2:A21)=0;НАИМЕНЬШИЙ(A2:A21;СЧЁТЕСЛИ(A2:A21;0)+1);МИН(A2:A21))
2 вариант
=МИН(ЕСЛИ(A2:A21>0;A2:A21)) формула массива (вводиться через одновременное нажатие Ctrl+Shift+Enter)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
sizopДата: Пятница, 23.01.2009, 08:31 | Сообщение # 3
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
Quote
конце первой необходимой Вам строки нажмите Alt+Enter

huh не работает, срабатывает как Enter, только курсор остается на этой же ячейке
 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 05.02.07 (Игнорирование нулевых значений)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz