Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 27.10.06 (Рассчет среднего значения)
27.10.06
sizopДата: Вторник, 20.01.2009, 19:41 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
Название: Рассчет среднего значения

Средние значения очень часто используются для анализа различных данных. Существует встроенная функция, которая рассчитывает среднее значение, однако из-за определенных особенностей Вашей информации (наличия информации), она не всегда может корректно работать.


Стандартная (штатная) функция Excel для рассчета среднего значения (например, в диапазоне A1:A8):


=СРЗНАЧ(A1:A8)

Ее аналог с использованием двух функций, =СУММ() и =СЧЁТ():


=СУММ(A1:A8)/СЧЁТ(A1:A8)

Примечание: как известно "среднее значение" по определению рассчитывается как общая сумма на количество. А что делать, если некоторые данные в анализируемом диапазоне не заполненны, либо стоит 0 там, где его не может быть, либо вместо числа стоит текст? Ведь в этом случае формулы =СРЗНАЧ(A1:A8) и/или =СУММ(A1:A8)/СЧЁТ(A1:A8) могут возвратить некорректный результат. Ниже рассмотрен вариант, который учитывает некоторые нюансы.


=СУММЕСЛИ(A1:A8;">0")/СЧЁТЕСЛИ(A1:A8;">0")

Эта формула, рассчитывает среднее значение только для положительных чисел входящих в указанный диапазон (формула будет полезна в том случае, если у Вас данные для которых рассчитывается среднее, никогда не могут быть отрицательными или равными нулю, а если они =0 или отрицательные, то это означает, что их нет или данные с ошибкой). Таким образом, даже не смотря на то, что в указанном диапазоне могут присутствовать ошибочные данные Вы будете получать среднее значение только для корректных данных.

ПРОВЕРКА ДАННЫХ. Проверка введенных данных очень актуальный вопрос. Сочетание рассмотренных формул и функции ЕСЛИ, это еще один способ проверить были ли верны все данные в указанном диапазоне. Вариант формулы:
=ЕСЛИ(СРЗНАЧ(A1:A8)-СУММЕСЛИ(A1:A8;">0")/СЧЁТЕСЛИ(A1:A8;">0")=0;"Все правильно";"Ошибка")

Дополнение к формуле прошлого выпуска

Название: Определение сегодняшней даты с использованием функции =СЕГОДНЯ()

В прошлом выпуске рассылки были приведены следующие формулы:


=СЦЕПИТЬ("Сегодня ";ТЕКСТ(C1;"Д ММММ, ГГГГГ");" года")


="Сегодня "&ТЕКСТ(C1;"Д ММММ, ГГГГГ")&" года"

Подразумевалось, что в ячейке C1 находится функция-формула =СЕГОДНЯ(). Однако, можно, конечно же, втавить эту функцию в рассмотренные формулы, результат останется прежним, а формулы, соответственно, преобразятся и примут следующий вид:


=СЦЕПИТЬ("Сегодня ";ТЕКСТ(СЕГОДНЯ();"Д ММММ, ГГГГГ");" года")


="Сегодня "&ТЕКСТ(СЕГОДНЯ();"Д ММММ, ГГГГГ")&" года"

Для ускорения работы в Excel (сочетание клавиш Excel)


"Горячие" клавиши Excel: Повтор предыдущего действия

Очень полезное сочетание клавишь (даже всего лишь одна клавиша - функциональная) для повтора предыдущего действия - F4. Не знаю, сколько Вы найдете ей разнообразных применений, но я, например, чаще всего ей пользуюсь при вставке определенного количества строк. Довольно удобно - ставь курсор куда тебе нужно да нажимай F4 столько раз, сколько тебе необходимо вставить строк.

Знаете ли Вы что в Excel…


…если Вы попытаетесь ввести в ячейку текст, начинающийся с символа "+" (плюс) или "-" (минус) Эксель воспримет это как попытку ввести формулу и выдаст сообщение об ошибке!. Что же делать, если Вы хотите, чтобы в ячейке был, например, такой текст: "+/- к прошлому месяцу" (как вариант в качестве заголовка столбца в таблице с анализом данных)?

ОТВЕТ: чтобы ввести текст, начинающийся с символа "+" или "-" необходимо в самом начале строки ввести ' (значок одиночной кавычки, который обычно находится там, где русская буква "Э" при включенной английской раскладке клавиатуры, конечно). Важное замечание: этот символ не виден ни на листе (только если Вы войдете в режим редактирования ячейки), ни при выводе на печать.


Если Вам необходимо готовое решение какой-либо Вашей проблемы в Excel, Вы можете оставить свое сообщение c описанием задачи на нашем форуме
 
AuthorДата: Четверг, 22.01.2009, 14:32 | Сообщение # 2
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Знаете ли Вы, что?...
что можно ввести ' (значок одиночной кавычки) не вводя его?

Как это сделать читайте в выпуске от 22.01.09 smile



Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
sizopДата: Четверг, 22.01.2009, 15:58 | Сообщение # 3
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
Author, интрижка? blink
 
AuthorДата: Четверг, 22.01.2009, 17:14 | Сообщение # 4
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
да smile


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 27.10.06 (Рассчет среднего значения)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz