Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 30.08.06 (День недели по дате)
30.08.06
sizopДата: Вторник, 20.01.2009, 19:29 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
Название формулы: День недели по дате

В Интернете на разных сайтах чаще всего встречается такой вариант этой формулы:

=ЕСЛИ(ДЕНЬНЕД(B3;2)=1;"Понедельник";ЕСЛИ(ДЕНЬНЕД(B3;2)=2;"Вторник";ЕСЛИ(ДЕНЬНЕД(B3;2)=3;"Среда";ЕСЛИ(ДЕНЬНЕД(B3;2)=4;"Четверг";ЕСЛИ(ДЕНЬНЕД(B3;2)=5;"Пятница";ЕСЛИ(ДЕНЬНЕД(B3;2)=6;"Суббота";"Воскресенье"))))))

Очевидно, что в ячейке B3 должна находиться дата, для которой определяется день недели!

Однако, этот вариант не оптимален, лучше и удобнее использовать эту формулу:

=ВЫБОР(ДЕНЬНЕД(B3;2);"Понедельник";"Вторник";"Среда";"Четверг";"Пятница";"Суббота";"Воскресенье")

Другие варианты этой же формулы:

=ВЫБОР(ДЕНЬНЕД(B3;2);"ПН";"ВТ";"СР";"ЧТ";"ПТ";"СБ";"ВС")

=ВЫБОР(ДЕНЬНЕД(B3;2);"Пн";"Вт";"Ср";"Чт";"Пт";"Сб";"Вс")

Совет по использованию Excel:


Чтобы выделить ячейки расположенные не рядом друг с другом (несмежные ячейки) необходимо удерживать клавишу Ctrl кликая на нужные ячейки или выделяя области «мышкой».

Для чего это бывает нужно? Например, для того, чтобы одинаково отформатировать ячейки или очистить их содержание (удалить данные или формулы в этих ячейках).

Для ускорения работы в Excel (сочетания клавиш Excel)


Закрытие документа - Ctrl+W (там где русская «ц»). Подходит как для Excel так и для Word.

Кому это может пригодиться? Всем, кто работает с большим количеством документов и кому жалко потратить 2-3 секунды, чтобы положить руку на «мышь», навести ее на «крестик» в углу и щелкнуть по нему левой (под указательным пальцем для правшей) кнопкой мыши.

Примечание: Ctrl+W означает одновременное нажатие клавиши Ctrl и клавиши W

 
AuthorДата: Среда, 21.01.2009, 12:36 | Сообщение # 2
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Есть еще интересный вариант формулы для определения дня недели определенной даты.
Если кому-то необходимо иногда использовать длинные (полные) названия дней недели, а иногда сокращенные, то в этом случае подойдет такая формула:
=ВЫБОР(ДЕНЬНЕД(B3;2)+7*$E$3;"Пн";"Вт";"Ср";"Чт";"Пт";"Сб";"Вс";"Понедельник";"Вторник";"Среда";"Четверг";"Пятница";"Суббота";"Воскресенье")

Как видно тут появляется дополнительная ячейка в формуле - $E$3, которая должна содержать 0 или 1.
В случае, если она содержит 0, формула будет возвращать сокращенные названия дней недели, если же 1, то полные.



Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 30.08.06 (День недели по дате)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz