Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Выборка по 3м критериям дата вид валюты курс покупки и прода
Выборка по 3м критериям дата вид валюты курс покупки и прода
AlexOMДата: Среда, 06.06.2012, 20:21 | Сообщение # 1
Группа: Пользователи
Сообщений: 4
Статус: Offline
Добрый день столкнулся с такой проблемой и не знаю как решить
есть задача курсы валют (евро доллар ...), с покупкой и продажей на отдельном листе и датой
На другом листе продажа валюты и покупка
Как сделать выбор курса по критериям
(Дата,Вид,Валюта)
Помогите а то уже весь мозг взорвал.

P.S. Учесть надо "курс продажи" и "курс покупки"
Прикрепления: 8095704.xlsx(10.6 Kb)
 
ABCДата: Среда, 06.06.2012, 21:11 | Сообщение # 2
Группа: Проверенные
Сообщений: 28
Статус: Offline
проверьте
Code
=ИНДЕКС(курс!$B$3:$G$4;ПОИСКПОЗ($A3;курс!$A$3:$A$4;0);ПОИСКПОЗ($D3;курс!$B$1:$G$1;0)+ПРОСМОТР($C3;{"покупка";"продажа"};{0;1}))


Сообщение отредактировал ABC - Среда, 06.06.2012, 21:35
 
AlexOMДата: Четверг, 07.06.2012, 00:27 | Сообщение # 3
Группа: Пользователи
Сообщений: 4
Статус: Offline
Огромное человеческое спасибо
 
AlexOMДата: Четверг, 07.06.2012, 03:22 | Сообщение # 4
Группа: Пользователи
Сообщений: 4
Статус: Offline
А если на данную дату курса нет как взять предыдущий курс?
 
ABCДата: Четверг, 07.06.2012, 08:07 | Сообщение # 5
Группа: Проверенные
Сообщений: 28
Статус: Offline
примерно так

Code
=ИНДЕКС(курс!$B$3:$G$4;ПОИСКПОЗ(ВПР($A4;курс!$A$3:$A$4;1);курс!$A$3:$A$4;0);ПОИСКПОЗ($D4;курс!$B$1:$G$1;0)+ПРОСМОТР($C4;{"покупка";"продажа"};{0;1}))
 
AlexOMДата: Четверг, 07.06.2012, 15:23 | Сообщение # 6
Группа: Пользователи
Сообщений: 4
Статус: Offline
спасибо большое
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Выборка по 3м критериям дата вид валюты курс покупки и прода
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz