Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подсчет суммы столбца через строку
Подсчет суммы столбца через строку
BlackswillДата: Вторник, 12.04.2011, 17:23 | Сообщение # 1
Группа: Пользователи
Сообщений: 1
Статус: Offline
Суть такова: В одном столбце идут значения цены и кол-ва шт. и нужно посчитать только значения цены
Например:
30,00
3,
25,00
1
48,00
5
Итого: 103 (сумма без кол-ва)
 
vladДата: Среда, 13.04.2011, 15:24 | Сообщение # 2
Группа: Модераторы
Сообщений: 720
Статус: Offline
Если цены в денежном формате и не смущает доп. столбец то можно так.
Прикрепления: test.xls(13.5 Kb)
 
Serge_007Дата: Суббота, 16.04.2011, 06:14 | Сообщение # 3
Группа: Проверенные
Сообщений: 468
Статус: Offline
Если цены в денежном формате, но кол-во всегда меньше 10 можно так:
Code
=СУММПРОИЗВ((ДЛСТР(D1:D6)=2)*D1:D6)

Для текстового формата несколько решений в файле.

Прикрепления: Blackswill.xls(23.5 Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
DV68Дата: Суббота, 16.04.2011, 07:08 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если ориентироваться на название темы, т.е. "Подсчет суммы столбца через строку"
то можно так:
Code
=СУММПРОИЗВ(ОСТАТ(СТРОКА(A1:A6);2);A1:A6)

или, если суммы в четных строках, то так:
Code
=СУММПРОИЗВ((ОСТАТ(СТРОКА(A1:A6);2)=0)*A1:A6)
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подсчет суммы столбца через строку
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz