Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Макрос или формула? (множестенный фильтр, гиперссылки)
Макрос или формула?
sedovДата: Вторник, 31.08.2010, 05:31 | Сообщение # 1
Группа: Проверенные
Сообщений: 11
Статус: Offline
Можно ли сделать фильтр не по одному столбцу .а по нескольким с одним условием, Например равно a? чтобы остались следующие варианты:
а 0 0 0
0 a 0 a
0 0 a 0
и им подобные вне зависимости от того в каких из выбранных столбцов находится нужный параметр

И второй вопрос. на листе в ячейках есть большое количество гиперссылок на внешние файлы картинок каталога.
а) как можно поменять путь к папке с этими картинками в групповом режиме, а не заходить в каждую "Изменить гиперссылку"
б) присвоить всем гиперссылкам примечания вида "крупнее" вместо отображения пути к файлу, так же разом для группы

 
DV68Дата: Среда, 01.09.2010, 16:46 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
По первому вопросу:
В свободном столбце пишем формулу:
=СЧЁТЕСЛИ(A2:C2;"а")>0
по этому столбцу фильтруем.


Сообщение отредактировал DIM5955 - Среда, 01.09.2010, 16:47
 
DV68Дата: Среда, 01.09.2010, 19:03 | Сообщение # 3
Группа: Модераторы
Сообщений: 648
Статус: Offline
2. а) Ctrl+H
Найти: пишем(или вставляем предварительно скопированное) то, что надо заменить
Заменить: соответственно на что меняем.
Заменить все.
 
sedovДата: Четверг, 02.09.2010, 00:56 | Сообщение # 4
Группа: Проверенные
Сообщений: 11
Статус: Offline
спасибо. не догадался.

а с 2б что делать?(

 
vladДата: Четверг, 02.09.2010, 12:41 | Сообщение # 5
Группа: Модераторы
Сообщений: 720
Статус: Offline
Quote (sedov)
спасибо. не догадался. а с 2б что делать?(

То же самое что и 2а.В заменить к имени файла добавляем требуемое имя, например "крупнее".
 
sedovДата: Суббота, 04.09.2010, 04:28 | Сообщение # 6
Группа: Проверенные
Сообщений: 11
Статус: Offline
не работает ни 2а ни 2б
в одну ячейку вставлена ссылка на эту тему http://sizop.my1.ru/forum/10-488-1
через ctrl+h ссылка не цепляется
Прикрепления: 2877195.xls(23.0 Kb)
 
vladДата: Суббота, 04.09.2010, 20:39 | Сообщение # 7
Группа: Модераторы
Сообщений: 720
Статус: Offline
В ячейке B3-H3 формула =ГИПЕРССЫЛКА("http://www.mail.ru/";"поиск")
Ctrl+H
Найти =ГИПЕРССЫЛКА("http://www.mail.ru/";"поиск")
Заменить=ГИПЕРССЫЛКА("http://www.yandex.ru/";"тындекс")
В примере заменил три ячейки в строке.
Прикрепления: 8940947.xls(24.0 Kb)
 
sedovДата: Воскресенье, 05.09.2010, 02:23 | Сообщение # 8
Группа: Проверенные
Сообщений: 11
Статус: Offline
vlad, спасибо больше. не знал что в поиск можно формулу задавать
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Макрос или формула? (множестенный фильтр, гиперссылки)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz