Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помогите пожалуйста
Помогите пожалуйста
StefДата: Среда, 28.03.2012, 13:11 | Сообщение # 1
Группа: Пользователи
Сообщений: 2
Статус: Offline
В ячейку А1 вводим от 0 до 999. В ячейку В1 нужно ввести формулу, которая возращает произведение цифр числа если оно трехзначное. Сумму числа если оно двузначное. Само число если оно однозначное.
Если число не является целым или выходит за рамки указанного диаппазона, то формула выдает сообщение о соотв-й ошибки.
 
Serge_007Дата: Среда, 28.03.2012, 13:32 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Code
=ЕСЛИ(ИЛИ(A1-ЦЕЛОЕ(A1);ИЛИ(A1<0;A1>999));"ошибка";ВЫБОР(ДЛСТР(A1);A1;СУММ(--ПСТР(A1;{1:2};1));ПРОИЗВЕД(--ПСТР(A1;{1:2:3};1))))


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Serge_007Дата: Среда, 28.03.2012, 13:37 | Сообщение # 3
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Stef)
формула выдает сообщение о соотв-й ошибки.

О соответствующей?
Тогда так:
Code
=ЕСЛИ(A1-ЦЕЛОЕ(A1);"Число не является целым";ЕСЛИ(ИЛИ(A1<0;A1>999);"Число выходит за пределы указанного диапазона";ВЫБОР(ДЛСТР(A1);A1;СУММ(--ПСТР(A1;{1:2};1));ПРОИЗВЕД(--ПСТР(A1;{1:2:3};1)))))


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
StefДата: Среда, 28.03.2012, 14:13 | Сообщение # 4
Группа: Пользователи
Сообщений: 2
Статус: Offline
спасибо
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помогите пожалуйста
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz