Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помогите составить формулу >или=
Помогите составить формулу >или=
ПятровнаДата: Пятница, 04.11.2011, 16:26 | Сообщение # 1
Группа: Пользователи
Сообщений: 8
Статус: Offline
Помогите составить формулу, чтобы выбирала людей в возрасте от 60 до 74 лет.(60 и старше, и 74 и младше.)
Прикрепления: 6272967.xls(458Kb)
 
DV68Дата: Пятница, 04.11.2011, 22:42 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote
Ну что здесь не так?

А вообще все не так.
Начнем с того, что данных, удовлетворяющих условиям, в таблице просто нет
Даже если бы формула была составлена правильно, все равно бы было 0.
Но и формула составлена совершенно неправильно.
Вот как должно было быть:
Code
=СУММПРОИЗВ((E2:E5087="I10")+(E2:E5087="I11");(C2:C5087>=60)*(C2:C5087<=74))

Но и это еще не все.
У Вас числа в столбце С записаны как текст и формула их будет воспринимать как текст.
Лучше их перевести в числа. Или так:
Code
=СУММПРОИЗВ((E2:E5087="I10")+(E2:E5087="I11");(C2:C5087>="60")*(C2:C5087<="74"))

Почитайте справку по функциям, там все подробно написано, да еще и с примерами
 
ПятровнаДата: Пятница, 04.11.2011, 23:10 | Сообщение # 3
Группа: Пользователи
Сообщений: 8
Статус: Offline
Большое спасибо.
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помогите составить формулу >или=
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz