Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Вопросик по формуле "Если, то" (Вопросик по формуле "Если, то")
Вопросик по формуле "Если, то"
SnarkДата: Среда, 17.08.2011, 20:02 | Сообщение # 1
Группа: Пользователи
Сообщений: 3
Статус: Offline
Ребят, смотрите, есть таблица, которую периодически надо пополнять.
В ней довольно много данных, но есть 1 закономерность, которую можно оптимизировать.
Имеется столбик в котором идут наименования компаний, и есть столбик в котором напротив каждой компании указывается определенное число, всегда одно и то же для одной компании. Но для 50% компаний это число одно и то же, То есть для "Компания1", "Компания2","компания3" и т.п. например это число 5. а для "Компания4", "Компания6", это число 7. При дополнении таблицы хотелось бы сделать так, чтобы при выборе компаний по заданным параметрам это число заносилось в определенную ячейки новой строки, которой таблица дополняется.
Через функцию "Если, то". вот поясните плиз как это грамотно сделать. Всем спасибо.

П.С. компаний больше 5 десятков, но у 80% цифры повторяются. Через "Если, то", пишет, что задано слишком много аргументов (2 условия задать получается, а 3-е уже не лезет), это не беря во внимание, что на каждое условие нужно несколько компаний прикрепить.
Делал примерно так............ =ЕСЛИ(A2="Компания1";5;ЕСЛИ(A2="Компания 2";7))


Сообщение отредактировал Snark - Среда, 17.08.2011, 20:14
 
Serge_007Дата: Четверг, 18.08.2011, 00:14 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Многа букаф...
Читать не стал - давайте пример.


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Serge_007Дата: Четверг, 18.08.2011, 00:16 | Сообщение # 3
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Snark)
...есть таблица...

Опять-таки есть у Вас. У нас нет.
Будет таблица - будет решение.
Секретные сведения замените на трусы-пулемёты.


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
SnarkДата: Четверг, 18.08.2011, 00:45 | Сообщение # 4
Группа: Пользователи
Сообщений: 3
Статус: Offline
Получилось сделать только для двух компаний, больше - пишет шибку в формуле
Прикрепления: _Microsoft_Exce.xlsx(11Kb)
 
Serge_007Дата: Четверг, 18.08.2011, 01:18 | Сообщение # 5
Группа: Проверенные
Сообщений: 468
Статус: Offline
Code
=ВПР(A1;$E$4:$F$12;2;0)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
SnarkДата: Четверг, 18.08.2011, 01:53 | Сообщение # 6
Группа: Пользователи
Сообщений: 3
Статус: Offline
Quote (Serge_007)
Code
=ВПР(A1;$E$4:$F$12;2;0)


Шаман, однако!
Спасибо! =)
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Вопросик по формуле "Если, то" (Вопросик по формуле "Если, то")
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz