Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Перевод текста в сумму чисел. (Перевод всех букв в цифры, суммирование.)
Перевод текста в сумму чисел.
Сияющая_ИзобилиемДата: Пятница, 10.06.2011, 16:36 | Сообщение # 1
Группа: Пользователи
Сообщений: 2
Статус: Offline
Доброго дня!
Подскажите как написать формулу что бы текст переводился в сумму чисел.
Допустим каждой букве присвоен свой номер: А-1, Б-2, В-3 и т.д.
сумма слова "Анна" = 32
сумма предложения "Анна передай чайник" = 170

Заранее благодарю.
 
DV68Дата: Пятница, 10.06.2011, 17:14 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Без знаков препинания, строго по условию (формула массива):
Code
=СУММ(Ч(СМЕЩ(G1;ПОИСКПОЗ(ПСТР(A1;СТРОКА(1:99);1);F1:F35;0)-1;)))


-----------------------------
Добавлено позже:
Хотя так лучше, без доп таблицы и не надо вводить как формулу массива:
Code
=СУММПРОИЗВ(ПОИСК(ПСТР(ПОДСТАВИТЬ(A1;" ";);СТРОКА(A1:ИНДЕКС(A1:A999;ДЛСТР(ПОДСТАВИТЬ(A1;" ";))));1);"абвгдеёжзийклмнопрстуфхцчшщъыьэюя"))
Прикрепления: Summa_Bukv_DV.xls(20Kb)
 
DV68Дата: Суббота, 11.06.2011, 19:49 | Сообщение # 3
Группа: Модераторы
Сообщений: 648
Статус: Offline
Можно еще немного упростить, хотя автору топика это, по-моему, уже не интересно:
Code
=СУММПРОИЗВ(ПОИСК(ПСТР(A1;СТРОКА(A$1:ИНДЕКС($A$1:$A$999;ДЛСТР(A1)));1);
" абвгдеёжзийклмнопрстуфхцчшщъыьэюя")-1)
 
Сияющая_ИзобилиемДата: Среда, 15.06.2011, 09:57 | Сообщение # 4
Группа: Пользователи
Сообщений: 2
Статус: Offline
Quote (DV68)
Можно еще немного упростить, хотя автору топика это, по-моему, уже не интересно:

Очень даже интересно, просто временно не могла войти в инет.

Все варианты хороши, Спасибо Вам огромное, это именно то что нужно было!
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Перевод текста в сумму чисел. (Перевод всех букв в цифры, суммирование.)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz