Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помогите написать формулу роизведения по 2-м условиям (не VBA)
Помогите написать формулу роизведения по 2-м условиям
TurentooДата: Понедельник, 06.06.2011, 12:12 | Сообщение # 1
Группа: Пользователи
Сообщений: 2
Статус: Offline
Здравствуйте.

Я уже что только ни пробовала, может вы поможете.

Есть, 4 столбца. В первом месяц, во втором имя человека, в третьем и четвертом цифры.
Например:
май -- петров --4--6
Июнь -- петров--5--2
май -- иванов --5--1
Июнь -- иванов -- 1--2

Нужно сделать (не VBA, а формулой в ячейке) следующий подсчет:

для каждого работника с месяцем Май умножить первый столбик с числами на второй столбик с числами этого же работника в месяце Июнь и сложить результаты.

Т.е.: 4*2+5*2=18

Хотя бы подскажите, какими функциями можно попробовать, 2 часа уже бьюсь с этим...
 
Serge_007Дата: Понедельник, 06.06.2011, 12:19 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Здравствуйте

Ответил здесь


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390


Сообщение отредактировал Serge_007 - Понедельник, 06.06.2011, 12:19
 
TurentooДата: Понедельник, 06.06.2011, 12:42 | Сообщение # 3
Группа: Пользователи
Сообщений: 2
Статус: Offline
К сожалению, в Вашем решении не учтены имена сотрудников, нет сравнения :(
Прикрепления: here_is_an_exam.xlsx(12Kb)


Сообщение отредактировал Turentoo - Понедельник, 06.06.2011, 12:59
 
Serge_007Дата: Понедельник, 06.06.2011, 13:48 | Сообщение # 4
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Turentoo)
в Вашем решении не учтены имена сотрудников


Code
=СУММПРОИЗВ(МАКС((A2:A5="may")*(B2:B5="q")*C2:C5);МАКС((A2:A5="june")*(B2:B5="q")*D2:D5))+СУММПРОИЗВ(МАКС((A2:A5="may")*(B2:B5="w")*C2:C5);МАКС((A2:A5="june")*(B2:B5="w")*D2:D5))


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помогите написать формулу роизведения по 2-м условиям (не VBA)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz