Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: Author  
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 05.02.09 (Аналог ВПР, но не по первому значению)
05.02.09
AuthorДата: Четверг, 05.02.2009, 20:31 | Сообщение # 1
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Файл к выпуску рассылки "Бесплатная рассылка: Excel - Готовые формулы" от 05.02.2009
Прикрепления: Bez_VPR.xls(18.5 Kb)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
AuthorДата: Пятница, 06.02.2009, 13:39 | Сообщение # 2
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline


Аналог ВПР, но не по первому значению

Название: Получение значения таблицы из той же строки, но другого столбца без использования функции ВПР()

Несмотря на то, что функция ВПР() является довольно удобной для решения некоторых задач, она, все же, не позволяет получить значение из той же строки, но другого столба для искомого значения, если это значение не находиться в крайнем левом столбце диапазона.

Например, в столбце правее находятся фамилии, а в столбце левее табельный номер. Необходимо зная фамилию получить табельный номер. С помощью функции ВПР() сделать это невозможно. Для решения подобных задач следует применять формулу, которую Вы найдете ниже. В ней использованы 2 функции: ИНДЕКС() и ПОИСКПОЗ().

=ИНДЕКС(A2:A10;ПОИСКПОЗ(D14;B2:B10;0);1)

Фамилии находятся в диапазоне B2:B10, табельные номера в диапазоне A2:A10. Фамилия, для которой мы хотим получить значение табельного номера в ячейке D14.

ВНИМАНИЕ! Формула будет возвращать корректный результат только в случае, если в списке не будет повторяющихся фамилий. В случае, если в D14 (искомая фамилия) будет введена фамилия, которая отсутствует в списке, формула вернет значение ошибки #Н/Д.

Файл-пример можно скачать в первом посте этой темы.

Сочетание клавиш Excel - активизация строки основного меню

Как активизировать основное меню в Excel с помощью клавиш

В основном окне Excel всегда сверху присутствует меню состоящее из следующих разделов: "Файл", "Правка", "Вид", "Вставка", "Формат", "Сервис", "Данные", "Окно", "Справка". Чтобы активизировать это меню достаточно нажать любую из клавишь Alt, либо F10. После этого подсвечивается первое слово этого меню - "Файл". Далее можно перемещаться по меню с помощью стрелок "влево"/"вправо". Стрелка "вниз" позволяет открыть (развернуть) каждый из пунктов меню.

Совет по использованию Excel

Чтобы превратить формулу в ее значение войдите в режим редактирования формулы (F2) нажмите F9 и ввод (Enter).

Предупреждение: используйте этот совет очень осторожно, так как Вы можете потерять нужную Вам формулу, заменив ее значением, которое она возвращала.




Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 05.02.09 (Аналог ВПР, но не по первому значению)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz