Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » поиск не точного значения
поиск не точного значения
BiaktrisaДата: Суббота, 17.11.2012, 17:03 | Сообщение # 1
Группа: Проверенные
Сообщений: 32
Статус: Offline
хотел сказать огромное спасибо форуму с его помощью понял как самому составлять хитрые формулы ))
вот теперь вопрос есть ли функция которая ищет не точное значение а к примеру известна часть слова а функция возвращала бы все слово целиком....
надеюсь понятно спросил. спасибо

пример в какой нибудь ячейке введен текст "с новым годом" но нам известно что в искомом значении есть точно слово "годом" но вернуть хотим полностью все значение ячейки

есть что нить подобное а то пока не нахожу что то
 
DV68Дата: Суббота, 17.11.2012, 21:18 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Можно так:
Code
=ВПР("*годом*";F11:F17;1;)
 
BiaktrisaДата: Суббота, 17.11.2012, 22:10 | Сообщение # 3
Группа: Проверенные
Сообщений: 32
Статус: Offline
Quote (DV68)
=ВПР("*годом*";F11:F17;1;)

похоже.... а как обратиться чтоб в формуле не прописывать "годом" а чтоб это бралось из ячейки а1 к примеру?
 
DV68Дата: Воскресенье, 18.11.2012, 10:44 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Так:
Code
=ВПР("*&A1&*";F11:F17;1;)
 
BiaktrisaДата: Воскресенье, 18.11.2012, 16:20 | Сообщение # 5
Группа: Проверенные
Сообщений: 32
Статус: Offline
Quote (DV68)
=ВПР("*&A1&*";F11:F17;1;)

что то не работает так
 
DV68Дата: Воскресенье, 18.11.2012, 20:23 | Сообщение # 6
Группа: Модераторы
Сообщений: 648
Статус: Offline
Прошу прощения, правил прямо на форуме, не проверил - забыл кавычки:
Code
=ВПР("*"&A1&"*";F11:F17;1;)
 
BiaktrisaДата: Воскресенье, 18.11.2012, 22:31 | Сообщение # 7
Группа: Проверенные
Сообщений: 32
Статус: Offline
Quote (DV68)
=ВПР("*"&A1&"*";F11:F17;1;)

спасибище огромное...... я даже не подозревал что так можно обращаться
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » поиск не точного значения
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz