Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подсчет ячеек с содержанием цифр
Подсчет ячеек с содержанием цифр
Andrey3669Дата: Пятница, 01.06.2012, 19:19 | Сообщение # 1
Группа: Пользователи
Сообщений: 4
Статус: Offline
Доброго времени! подскажите пожалуйста как мне прописать формулу которая будет считать ячейки только с содержанием цифр и цифр вместе с текстом в одной ячейке!
Например строки содержит:
B1 - №456
B2 - Андрей
B3 - 456
B4 - Андрей456

Вот ячейки (B1;B3;B4) мне нужно посчитать, а (B2) - нужно пропустить, итог должен быть =3

Заранее благодарен=)
 
DV68Дата: Пятница, 01.06.2012, 19:41 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Первое, что пришло в голову, наверняка можно проще:
Code
=СУММ(--(МУМНОЖ(--ЕОШ(ПОИСК({0;1;2;3;4;5;6;7;8;9};A1:A4));{1:1:1:1:1:1:1:1:1:1})<>10))

Code
=СУММ(--(МУМНОЖ(--ЕОШ(-ПСТР(A1:A4;СТОЛБЕЦ(A1:II1);1));СТРОКА(1:243)^0)<>243))

Code
=СУММ(--(МУМНОЖ(-ЕЧИСЛО(-ПСТР(A1:A4;СТОЛБЕЦ(A1:II1);1));СТРОКА(1:243)^0)<0))
 
ABCДата: Пятница, 01.06.2012, 19:51 | Сообщение # 3
Группа: Проверенные
Сообщений: 28
Статус: Offline
вариант:
Прикрепления: 9146963.xls(29.5 Kb)
 
DV68Дата: Пятница, 01.06.2012, 19:56 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
ABC,
Вашу формулу необязательно вводить как формулу массива
Можно еще и так:
Code
=--ИЛИ(ЕЧИСЛО(ПОИСК({0;1;2;3;4;5;6;7;8;9};A1)))
 
Andrey3669Дата: Воскресенье, 03.06.2012, 19:31 | Сообщение # 5
Группа: Пользователи
Сообщений: 4
Статус: Offline
Спасибо огромное!!!
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подсчет ячеек с содержанием цифр
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz