Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подсчет суммы на последнюю дату (Не понимаю, как построить формулу)
Подсчет суммы на последнюю дату
kallingДата: Понедельник, 28.05.2012, 13:34 | Сообщение # 1
Группа: Пользователи
Сообщений: 5
Статус: Offline
Вопрос такой.
Есть таблица, в которой идет перечень, допустим, врачей с датами и количеством пациентов.
Количество пациентов меняется в зависимости от даты. Например, вчера количество пациентов было 10, а сегодня уже 15.

Мне нужно удалить дубликаты и оставить только значения на последнюю дату. Мне это видится, как какая-то формула, которая будет обозначать TRUE/FALSE в зависимости от того, эта ли дата последняя или нет. Сложность в том, что все даты разные и искать надо среди записей одного врача.

Для наглядности - картинка, что я имею ввиду, что мне нужно удалить, а что оставить. Может быть у кого-то будут идеи.

Заранее спасибо!
Прикрепления: excel_task.bmp(476.4 Kb)


Сообщение отредактировал kalling - Понедельник, 28.05.2012, 14:07
 
Serge_007Дата: Понедельник, 28.05.2012, 14:07 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (kalling)
нужно удалить дубликаты

Quote (kalling)
это видится, как какая-то формула


Формулы ничего удалять не могут.

ЗЫ Картинку посмотреть не могу, да и не нужна она


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
kallingДата: Понедельник, 28.05.2012, 14:09 | Сообщение # 3
Группа: Пользователи
Сообщений: 5
Статус: Offline
Quote (Serge_007)
Формулы ничего удалять не могут.


я пояснила дальше, что мне не нужно, чтобы формула удаляла, мне нужно, чтобы напротив каждой строчки появилось какие-либо значение, например TRUE или FALSE в случае, если эта дата последняя и учитывать нужно именно ее. А все значения с непоследней датой я бы и сама удалила
 
Serge_007Дата: Понедельник, 28.05.2012, 14:18 | Сообщение # 4
Группа: Проверенные
Сообщений: 468
Статус: Offline
Тогда выкладывайте пример


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
kallingДата: Понедельник, 28.05.2012, 14:32 | Сообщение # 5
Группа: Пользователи
Сообщений: 5
Статус: Offline
не знаю, увидите ли вы так

http://postimage.org/image/rgkuxxy6h/
 
Serge_007Дата: Понедельник, 28.05.2012, 14:59 | Сообщение # 6
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Serge_007)
Картинку посмотреть не могу, да и не нужна она

Quote (Serge_007)
выкладывайте пример


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
DV68Дата: Понедельник, 28.05.2012, 15:07 | Сообщение # 7
Группа: Модераторы
Сообщений: 648
Статус: Offline
Типа такого:
Code
=СЧЁТЕСЛИ(B$3:B$15;B3)=СЧЁТЕСЛИ(B$3:B3;B3)

обращаем внимание на $
Нагляднее в Вашем примере .xls
 
kallingДата: Понедельник, 28.05.2012, 15:41 | Сообщение # 8
Группа: Пользователи
Сообщений: 5
Статус: Offline
Serge_007, а, я думала вы приложенный файл не можете просмотреть, ссылку видимо тоже тогда примерно так

Имя врача Диагноз Кол-во пациентов Дата
Иванов Иван Грипп 20 01.01.2012
Иванов Иван Грипп 30 23.03.2012
Иванов Иван Грипп 15 28.05.2012
Сидоров Петр ОРВИ 5 02.04.2012
Сидоров Петр ОРВИ 5 04.05.2012
Сидоров Петр ОРВИ 5 19.05.2012

Соответственно, на строках Иванов Иван с датами 01.01 и 23.03 должно стоять FALSE, на строке Иванов Иван 28.05.2012 - TRUE
Также с Сидоровым, 02.04 и 04.05 - FALSE, 19.05 - TRUE
 
Serge_007Дата: Понедельник, 28.05.2012, 16:48 | Сообщение # 9
Группа: Проверенные
Сообщений: 468
Статус: Offline
Блин, три раза просил выложить пример. Что сложно? Лень? Тямы не хватило?
Нарисовал сам. Формулы массива вводятся нажатием Ctrl+Shift+Enter

Quote (DV68)
Code
=СЧЁТЕСЛИ(B$3:B$15;B3)=СЧЁТЕСЛИ(B$3:B3;B3)


Или покороче, но массивно:
Code
=МАКС((A$2:A$7=A2)*D$2:D$7)=D2
Прикрепления: kalling.xls(24.5 Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Serge_007Дата: Понедельник, 28.05.2012, 16:48 | Сообщение # 10
Группа: Проверенные
Сообщений: 468
Статус: Offline
.
Прикрепления: 3570311.xls(24.5 Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
kallingДата: Понедельник, 28.05.2012, 17:02 | Сообщение # 11
Группа: Пользователи
Сообщений: 5
Статус: Offline
Сергей, большое спасибо, извините, что ступила, пример у меня и есть в xls, вы бы написали, что его нужно в хls выложить, а не в других форматах, я бы выложила. Спасибо еще раз!
 
Serge_007Дата: Понедельник, 28.05.2012, 17:23 | Сообщение # 12
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (kalling)
вы бы написали, что его нужно в хls выложить

А в чём ещё можно выложить ПРИМЕР на форуме по EXCEL?!


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подсчет суммы на последнюю дату (Не понимаю, как построить формулу)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz