Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Адрес ячейки (поиск по критерию и суммирование)
Адрес ячейки
MihaДата: Среда, 21.12.2011, 15:59 | Сообщение # 1
Группа: Пользователи
Сообщений: 5
Статус: Offline
Ребята, нижайше прошу Вашей помощи.

Суть задачи.
В приложенном мной файле таблица.
Задача находить суммы значений взятых по модулю в столбцах искомого диапазона дат.
т.е. Вручную задается дианазон дат : В2 - начальная дата диапазона, B3 - коечная дата диапазона. Нужно суммировать модули соответствующих этому диапазону дат значений в столбцах Ромашки, Сумма1 и Сумма2
Прикрепления: 6136615.xls(14.5 Kb)
 
DV68Дата: Среда, 21.12.2011, 17:14 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
В ячейку В20:
Code
=СУММЕСЛИ($A7:$A19;">="&$B2;B7:B19)-СУММЕСЛИ($A7:$A19;">"&$B3;B7:B19)

и копируем формулу в Е20 и F20
 
MihaДата: Среда, 21.12.2011, 21:22 | Сообщение # 3
Группа: Пользователи
Сообщений: 5
Статус: Offline
Огромное спасибо за внимание к моему посту!
но это не совсем то, что надо.
Идея в том, что таблица будет заполняться, и эти расчеты по диапазону дат может быть очень разным, да и сам диапазон может быть очень разным (за какое-то количество дней, за несколько месяцев, за год, наконец) и самое важное, что все значения должны перед суммированием браться по модулю (ABS), да ко всему же суммы эти выводятся в соответствующие ячейки вверху - в C2, D2,E2, т.к. область строк от 1ой до 5ой будет "закрепленной областью"

т.е. в ячейку B2 я ввожу начальную дату периода, в B3 - конечную, а в С2, D2, E2 выводятся соответствующие этому периоды суммы взятых по модулю значений из одноименных столбцов таблицы данных

Очень прошу помощи...
С Ув. Миха.
 
Serge_007Дата: Четверг, 22.12.2011, 13:55 | Сообщение # 4
Группа: Проверенные
Сообщений: 468
Статус: Offline
Используйте имена на динамических диапазонах.
Или меняйте диапазоны в формуле вручную.


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
MihaДата: Четверг, 22.12.2011, 14:34 | Сообщение # 5
Группа: Пользователи
Сообщений: 5
Статус: Offline
спсибо за совет. ,Но я так давно этим занимался в интитуте, что на слух сейчас - "динамический диапазон" для меня почти как нецензурная брань )... Пипец короче... Хоть головой об стену
 
DV68Дата: Четверг, 22.12.2011, 14:52 | Сообщение # 6
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если не заморачиваться с динамическими диапазонами, то так Е2:
Code
=СУММПРОИЗВ(ABS(ИНДЕКС(B7:B10000;ПОИСКПОЗ($B2;$A7:$A10000;)):ИНДЕКС(B7:B10000;ПОИСКПОЗ($B3;$A7:$A10000;))))

С диапазонами суммирования думаю разберетесь.
 
MihaДата: Четверг, 22.12.2011, 15:57 | Сообщение # 7
Группа: Пользователи
Сообщений: 5
Статус: Offline
Глубокоуважаемый DV68, моя признательность Вам не знает границ! Все работает как надо!
Я был бы очень рад иметь возможность Вас поблагодарить!
Вы в каком городе живете?
 
DV68Дата: Четверг, 22.12.2011, 16:18 | Сообщение # 8
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (Miha)
Вы в каком городе живете?

Далеко от Вас. В Хабаровске.
 
MihaДата: Четверг, 22.12.2011, 16:40 | Сообщение # 9
Группа: Пользователи
Сообщений: 5
Статус: Offline
добрую бутылку по почте не отправишь ((((
Предложу пошлость - можно я вам на телефон денежку положу?
 
DV68Дата: Четверг, 22.12.2011, 16:57 | Сообщение # 10
Группа: Модераторы
Сообщений: 648
Статус: Offline
Я Вам послал личное сообщение
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Адрес ячейки (поиск по критерию и суммирование)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz