Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » СУММЕСЛИ, а может другая формула (Числа, даты и заданный период)
СУММЕСЛИ, а может другая формула
ИнтересуюсьДата: Вторник, 06.09.2011, 19:52 | Сообщение # 1
Группа: Пользователи
Сообщений: 7
Статус: Offline
Здравствуйте! Задание такое: просуммировать числа столбца, соответствующие даты которых удовлетворяют периоду
Я пыталась волт таким образом использовать формулу:
СУММЕСЛИ($A$1:$A$6;">=01.01.2008AND=<31.01.2008";$D$1:$D$6) -не работает
Прикрепления: 2882935.xls(13.5 Kb)
 
DV68Дата: Среда, 07.09.2011, 03:06 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Добрый день!
Попробуйте так:
Code
=СУММПРОИЗВ(--(D$1:D$6>=--"01.01.2008");--(D$1:D$6<=--"31.01.2008");A$1:A$6)

или так:
Code
=СУММПРОИЗВ(--(D$1:D$6>=A10);--(D$1:D$6<=КОНМЕСЯЦА(A10;0));A$1:A$6)

Code
=СУММПРОИЗВ(СУММЕСЛИ(D$1:D$6;СТРОКА(ИНДЕКС(A:A;A10):ИНДЕКС(A:A;КОНМЕСЯЦА(A10;0)));A$1:A$6))

в D10 и растягиваем вниз.
Для 2003-го и старше(2000 и т.д.) должен быть подключен "пакет анализа"
 
ИнтересуюсьДата: Среда, 07.09.2011, 16:17 | Сообщение # 3
Группа: Пользователи
Сообщений: 7
Статус: Offline
Простите, а как узнать, подключен ли "пакет анализа"?
 
DV68Дата: Среда, 07.09.2011, 16:59 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (Интересуюсь)
а как узнать, подключен ли "пакет анализа"?

если не подключен, то вместо ответа будет =ИМЯ#
В 2003-м не помню, где-то во вкладке Сервис-Анализ.
 
ИнтересуюсьДата: Среда, 07.09.2011, 20:15 | Сообщение # 5
Группа: Пользователи
Сообщений: 7
Статус: Offline
Первая формула сработала, но т.к. лениво исправлять периоды в формуле (а автоматом не протягивается), решила испытать вторую формулу. И вот по ней выдает =ИМЯ#

Quote (DV68)
если не подключен, то вместо ответа будет =ИМЯ#


Так подключение пакета анализа было необходимо для всех формул или только для второй и третьей?
 
DV68Дата: Среда, 07.09.2011, 20:20 | Сообщение # 6
Группа: Модераторы
Сообщений: 648
Статус: Offline
Для двух последних.
Если нет пакета анализа, то пробуйте так:
Code
=СУММПРОИЗВ(--(D$1:D$6>=A10);--(D$1:D$6<=ДАТА(ГОД(A10);МЕСЯЦ(A10)+1;0));A$1:A$6)
 
HellyhelgaДата: Среда, 14.09.2011, 13:55 | Сообщение # 7
Группа: Пользователи
Сообщений: 2
Статус: Offline
Подскажите, пожалуйста!

Нужно просуммировать числа столбца - не все, а выборочно. Условие - фамилия менеджера. То есть из общего столбца отдельно суммировать результаты Иванова, отдельно - Петрова и т.д.
Прикрепления: 1028324.xls(13.5 Kb)


Сообщение отредактировал Hellyhelga - Среда, 14.09.2011, 13:58
 
ИнтересуюсьДата: Среда, 14.09.2011, 14:42 | Сообщение # 8
Группа: Пользователи
Сообщений: 7
Статус: Offline
Quote (Hellyhelga)
Нужно просуммировать числа столбца - не все, а выборочно. Условие - фамилия менеджера. То есть из общего столбца отдельно суммировать результаты Иванова, отдельно - Петрова и т.д.


Предлагаю вот так: Оставить в итоговых ячейках только фамилии. Внимание написание фамилии в итоговых ячейках должно полностью соответствовать написанию их в списке
в ячейку С14 написать вот такую формулу и протянуть ее до С16:
+СУММЕСЛИ(C$6:C$11;$B14;$B$6:$B$10)

См. прикрепление
Прикрепления: 1275342.xls(13.5 Kb)
 
Serge_007Дата: Среда, 14.09.2011, 15:47 | Сообщение # 9
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Hellyhelga)
...просуммировать числа столбца - не все, а выборочно. Условие - фамилия менеджера...

Пара решений во вложении.
Прикрепления: Hellyhelga.xls(19.0 Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
HellyhelgaДата: Пятница, 23.09.2011, 14:06 | Сообщение # 10
Группа: Пользователи
Сообщений: 2
Статус: Offline
Интересуюсь, Serge_007, Спасибо огромное! Именно то, что надо! Вариант Интересуюсь и первый из вариантов Serge_007 замечательные. Второе решение (с табличкой и выпадающим меню) просто шедевр, но могу на него только любоваться и завидовать, ибо повторить не в состоянии :(
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » СУММЕСЛИ, а может другая формула (Числа, даты и заданный период)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz