Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » суммировать ячейки (помогите пжл)
суммировать ячейки
eldarkosДата: Суббота, 14.05.2011, 23:44 | Сообщение # 1
Группа: Проверенные
Сообщений: 11
Статус: Offline
И по этой формуле что то проблема
почему то на строки в одном столбце которые рассположенны не по порядку не работает!!!
Пример: 150шт
левая строка
25шт
тоже левая строка
50шт и т.д
нужно суммировать 150шт + 25шт + 50шт которые рассположенны в одном столбце но в разных строках, я пытался вот так -
=СУММПРОИЗВ(--ПОДСТАВИТЬ(A1;A3;А5"шт";))&"шт" но что то не получается, подскажите пжл
Прикрепления: 4390629.xlsx(11.6 Kb)


Сообщение отредактировал eldarkos - Суббота, 14.05.2011, 23:45
 
Serge_007Дата: Воскресенье, 15.05.2011, 01:43 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Так надо:
Code
=СУММПРОИЗВ(--ЕСЛИ(НЕ(ЕОШ(НАЙТИ("шт";A5:A16)));ПОДСТАВИТЬ(A5:A16;"шт";"")))
Прикрепления: eldarkos.xls(27.0 Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Serge_007Дата: Воскресенье, 15.05.2011, 01:47 | Сообщение # 3
Группа: Проверенные
Сообщений: 468
Статус: Offline
&"шт" в конце добавьте, или форматом ячейки воспользуйтесь.
Прикрепления: eldarkos_2.xls(27.0 Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » суммировать ячейки (помогите пжл)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz