Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Сравнение по 3м параметрам и выбор совпадающего (Требуется выбрать совпадение, исходя из которого вбить знач.)
Сравнение по 3м параметрам и выбор совпадающего
ScenerДата: Воскресенье, 08.05.2011, 20:59 | Сообщение # 1
Группа: Пользователи
Сообщений: 2
Статус: Offline
Надо произвести сравнение параметров, чтобы после нахождения нужной таблицы, получить нужное значение из таблицы.
Например, сначала сравниваем параметр3, после совпадения параметр 1 и 2 и потом выбираем то, что находится в таблице внутри.
К сожалению, по форуму не нашел именно такого.
Буду очень признателен за ответ.
Спасибо.
Прикрепления: parameters.xls(39.0 Kb)


Сообщение отредактировал Scener - Воскресенье, 08.05.2011, 21:15
 
Serge_007Дата: Воскресенье, 08.05.2011, 22:36 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Что должно получиться в D2 и D3?


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
ScenerДата: Понедельник, 09.05.2011, 02:58 | Сообщение # 3
Группа: Пользователи
Сообщений: 2
Статус: Offline
D3 должен быть равен 760 (J34),
D4 - 690 (S37)
 
DV68Дата: Понедельник, 09.05.2011, 09:49 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если данных не так много, то можно ДВССЫЛ и именованные диапазоны (Ctrl+F3) использовать, но нужна доп таблица:
Прикрепления: _parameters_DV.xls(41.0 Kb)
 
DV68Дата: Понедельник, 09.05.2011, 10:41 | Сообщение # 5
Группа: Модераторы
Сообщений: 648
Статус: Offline
Хотя можно без всего вышесказанного такой вот страшной на первый взгляд формулой:
Code
=ИНДЕКС($H$7:$Z$73;A2+ИНДЕКС({0:0:12:12:12:24:24:36:36:48:48:60:60};
ПОИСКПОЗ(C2;{"90-120":"60-90":"40-60":"30-40":"25-30":"20-25":"15-20":"10-15":"7-10":"6-7":"5-6":"4-5":"3-4"};0));B2+ИНДЕКС({0:11:0:0:11:0:11:0:11:0:11:0:11};
ПОИСКПОЗ(C2;{"90-120":"60-90":"40-60":"30-40":"25-30":"20-25":"15-20":"10-15":"7-10":"6-7":"5-6":"4-5":"3-4"};0)))
Прикрепления: _parameters_DV_.xls(40.5 Kb)
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Сравнение по 3м параметрам и выбор совпадающего (Требуется выбрать совпадение, исходя из которого вбить знач.)
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz