Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » =СЛУЧМЕЖДУ()
=СЛУЧМЕЖДУ()
marabundoДата: Четверг, 29.04.2010, 23:04 | Сообщение # 1
Группа: Пользователи
Сообщений: 7
Статус: Offline
Есть необходимость ввести в 13 ячеек случайные УНИКАЛЬНЫЕ числа от 1 до 136. Т.е., в каждой ячейке должно быть неповторяющееся число в этом диапазоне. Пытался применить эту функцию вместе с ЕСЛИ:
1. Заполнение ячеек D5:P5 значениями:
=СЛУЧМЕЖДУ(1;136)
2. Нахождение повторов и их замена:
=ЕСЛИ(ЕСЛИ(D5<>E5;ЕСЛИ(D5<>F5;ЕСЛИ(D5<>G5;ЕСЛИ(D5<>H5;ЕСЛИ(D5<>I5;ЕСЛИ(D5<>J5;ЕСЛИ(D5<>K5;ЕСЛИ(D5<>L5;ЕСЛИ(D5<>M5;ЕСЛИ(D5<>N5;ЕСЛИ(D5<>O5;ЕСЛИ(D5<>P5;D5;))))))))))));D5;СЛУЧМЕЖДУ(1;$A$1))
Но этого мало, повторения продолжаются.
Если кто знает как их избежать, прошу поделиться.
 
DV68Дата: Пятница, 30.04.2010, 13:41 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Можно так:
=ПОИСКПОЗ(СЛУЧМЕЖДУ(2;136);ЕСЛИ(НЕ(СЧЁТЕСЛИ(A$1:A1;СТРОКА($1:$136)));СТРОКА($1:$136)))
формула массива, вводится одновременным нажатием конрт+шифт+ентер. При правильном вводе вокруг формулы появляются фигурные скобки.
Если поставить СЛУЧМЕЖДУ(1;136), то иногда будет выскакивать ошибка #Н/Д.
Прикрепления: Razn_sluch.xls(19.5 Kb)


Сообщение отредактировал DIM5955 - Пятница, 30.04.2010, 13:44
 
marabundoДата: Пятница, 30.04.2010, 17:37 | Сообщение # 3
Группа: Пользователи
Сообщений: 7
Статус: Offline
DIM5955
гран мерси, работает идеально! up
Формула для меня слишком мудреная, но вроде получается, что генерится интервал 2-136? Почему же тогда генерится 1-ца? Правда, статистически гораздо реже, чем 2-3-4
 
DV68Дата: Пятница, 30.04.2010, 17:52 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
1 может появляться, если в числах сверху есть 2. Даже очень редко может быть #Н/Д, но у меня было только один раз, когда сверху были и 1 и 2 и 3.
 
marabundoДата: Пятница, 30.04.2010, 18:44 | Сообщение # 5
Группа: Пользователи
Сообщений: 7
Статус: Offline
А можно задать интервал 2-137? Я пытался, но получал #Н/Д. Для меня важно, чтобы в переборе ГСЧ было136 чисел.
 
DV68Дата: Пятница, 30.04.2010, 19:44 | Сообщение # 6
Группа: Модераторы
Сообщений: 648
Статус: Offline
Ну там и так 1 проскакивает, так что 136 и есть. Или используйте СЛУЧМЕЖДУ(1;136), там не так часто ошибка выпадает.
 
marabundoДата: Пятница, 30.04.2010, 19:58 | Сообщение # 7
Группа: Пользователи
Сообщений: 7
Статус: Offline
ок, спасибо за помощь
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » =СЛУЧМЕЖДУ()
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz