Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Перенос последнего числа из добавляемого массива данных
Перенос последнего числа из добавляемого массива данных
TonTinДата: Четверг, 28.01.2010, 12:49 | Сообщение # 1
Группа: Проверенные
Сообщений: 16
Статус: Offline
Добрый день!

Не получается реализовать с помощью стандартных формул задачу переноса из некоторого массива данных последнего числа (при постоянном добавлении значений) в отдельную ячейку, посмотрите пож. прикрепленный файл, там есть пример и более подробные примечания.

Прикрепления: 22222.rar(2.0 Kb)
 
sizopДата: Четверг, 28.01.2010, 13:27 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
TonTin, к сожалению нет возможности на работе скачать архив. Но вот здесь есть готовое решение некоторой задачи, может Вам подойдет.
Quote

Возвращение последнего значения в столбце.
Если столбец, последнее значение которого нужно найти, не имеет пустых ячеек:
Доступно только для пользователей=СМЕЩ(А1;СЧЕТЗ(А:А)-1;0)
Если столбец может содержать пустые строки:
Доступно только для пользователей=ИНДЕКС(F1:F30;МАКС(СТРОКА(F1:F30)*(F1:F30<>""))) *
Эта формула возвращает содержимое последней не пустой ячейки в первых тридцати строках столбца F, не стоит злоупотреблять слишком большим количеством строк в столбце, это будет снижать скорость вычислений.
 
DV68Дата: Четверг, 28.01.2010, 15:26 | Сообщение # 3
Группа: Модераторы
Сообщений: 648
Статус: Offline
=ПРОСМОТР(9E+307;1/B5:B200;B5:B200)
или
=ПРОСМОТР(2;1/(B5:B200<>0);B5:B200)
 
TonTinДата: Понедельник, 01.02.2010, 16:23 | Сообщение # 4
Группа: Проверенные
Сообщений: 16
Статус: Offline
sizop и DIM5955 - спасибо Вам большое - ваши ответы мне очень помогли, извиняюсь за задержку с благодарностью!!
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Перенос последнего числа из добавляемого массива данных
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz