Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Расчет
Расчет
evgen_softДата: Среда, 04.11.2009, 19:14 | Сообщение # 1
Группа: Проверенные
Сообщений: 12
Статус: Offline
Доброго здоровья и с праздником Вас!! Прошу оказать содействие в данном файле.
Обьясняю, в первой вкладке список, кол-во проживающих, площадь и т.д. - забиваются в ручную, а во второй вкладке "расчет.." вручную вбивается только тариф остальное расчитывается и заполняется автоматом.
Все бы хорошо, НО не предусмотрел что есть еще и льготные категории, либо на одного человека из семьи, либо два, либо все сразу.
Добавлю, что нагромождение цифр в первом листе из-за того, что объектов будет четыре, и в каждом такие файлы (если есть такая возможность то помогите оптимизировать пожалуйста)
Если есть возможность, то необходимо добавить бланк в свободной форме(по аналогии ФИО, цена за ХВС, ГВС и т.д.), согласно столбцов во втором листе чтоб при пометке строки вылезал на бланке для каждого квартиросьемщика отдельно.
Прикрепления: version1.xls(73.0 Kb)


Сообщение отредактировал evgen_soft - Среда, 04.11.2009, 19:46
 
DV68Дата: Среда, 04.11.2009, 20:55 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
А в В2 (СЦЕПИТЬ('Общежитие 1'!E2;'Общежитие 1'!F2;))>1, это что? Потому что даже если F2 пусто, то все равно больше 1, может СЧЁТЗ('Общежитие 1'!E2:F2)>1 правильней?
Второе. В названии листов лучше, чтобы не было пробелов, можно использовать "_", например "Общежитие_1", чтобы в формулах не высвечивалось ' . Остальное другие подскажут, сегодня некогда. Еще вопрос:
льгота распространяется на все начисления и только на тех, у кого льгота?
 
evgen_softДата: Среда, 04.11.2009, 21:18 | Сообщение # 3
Группа: Проверенные
Сообщений: 12
Статус: Offline
Насчет замены - протестирую, пробел уберу спасибо.
Льгота может распространяться как на одного, на двоих, так и на всех, в зависимости количества проживающих, но не более.
 
DV68Дата: Четверг, 05.11.2009, 14:38 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если процент начисления по льготе выставляется самостоятельно, то так:
На листе Общежитие_1 встаем в ячейку Е3 =>нажимаем Ctrl+F3 => Создать => Имя:льгота => Диапазон:=1-Общежитие_1!$J2 => Ок. Далее там где надо умножаем на льгота, например для ячейки С3 листа "Расчет квартплаты":
=ЕСЛИ($B3>0;Квартплата*Общежитие_1!G2*льгота;""). Вообще много лишнего в формулах. Например непонятно зачем используется формула ПРОИЗВЕД, если внутри ее все перемножается.
 
evgen_softДата: Четверг, 05.11.2009, 15:10 | Сообщение # 5
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (DIM5955)
Если процент начисления по льготе выставляется самостоятельно

может выставляться, а может и не выставляться

Quote (DIM5955)
Вообще много лишнего в формулах.

DIM5955 Согласен, как смог

Quote (DIM5955)
Например непонятно зачем используется формула ПРОИЗВЕД, если внутри ее все перемножается.

Выдавала ошибку добавил, не исключаю что символы забыл какие то.


Сообщение отредактировал evgen_soft - Четверг, 05.11.2009, 15:20
 
vladДата: Четверг, 05.11.2009, 16:48 | Сообщение # 6
Группа: Модераторы
Сообщений: 720
Статус: Offline
Ничего не понял.
Необходимо ,чтобы рассчет льготников происходил на отдельном листе?
Quote (evgen_soft)
Например непонятно зачем используется формула ПРОИЗВЕД, если внутри ее все перемножается.

Выдавала ошибку добавил, не исключаю что символы забыл какие то.


Насчет этого ,убираете (ч/з найти-заменить "ПРОИЗВЕД") и все нормально работает(проверил).


Сообщение отредактировал vlad - Четверг, 05.11.2009, 16:48
 
evgen_softДата: Четверг, 05.11.2009, 18:52 | Сообщение # 7
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (vlad)
Ничего не понял. Необходимо ,чтобы рассчет льготников происходил на отдельном листе?

Немного не так.
Необходимо чтоб автоматом при заполнении столбов J и K в листе "общежитие_1" на листе расчет квартплаты сразу считалось с учетом этих льгот, или считалось как сейчас без их учета.
Quote (vlad)
Насчет этого ,убираете (ч/з найти-заменить "ПРОИЗВЕД") и все нормально работает(проверил).

Немного не понял, просто из формулы убрать?
 
vladДата: Четверг, 05.11.2009, 22:29 | Сообщение # 8
Группа: Модераторы
Сообщений: 720
Статус: Offline
Quote (evgen_soft)
Немного не понял, просто из формулы убрать?

Да.
Вместо =ЕСЛИ('Общежитие 1'!E2>0;ПРОИЗВЕД(Квартплата*'Общежитие 1'!G2);"")
получим =ЕСЛИ('Общежитие 1'!E2>0;Квартплата*'Общежитие 1'!G2;"")


Сообщение отредактировал vlad - Четверг, 05.11.2009, 22:33
 
evgen_softДата: Пятница, 06.11.2009, 02:19 | Сообщение # 9
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (vlad)
Необходимо ,чтобы рассчет льготников происходил на отдельном листе?

Разобрался, спасибо

 
vladДата: Пятница, 06.11.2009, 12:05 | Сообщение # 10
Группа: Модераторы
Сообщений: 720
Статус: Offline
Вот файл с предложенным примером рассчета.
Посмотрите может быть подойдет.
Прикрепления: 3975401.xls(112.0 Kb)


Сообщение отредактировал vlad - Пятница, 06.11.2009, 12:06
 
DV68Дата: Пятница, 06.11.2009, 15:22 | Сообщение # 11
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (evgen_soft)
Выдавала ошибку добавил, не исключаю что символы забыл какие то.

По формуле ПРОИЗВЕД для информации:
Описание
Функция ПРОИЗВЕД перемножает все числа, переданные как аргументы, и возвращает произведение. Например, если в ячейках A1 и A2 содержатся числа, формула =ПРОИЗВЕД(A1;A2) возвращает произведение этих чисел. Эту операцию также можно выполнить с помощью математического оператора умножения (*). Пример: =A1 * A2.

Функция ПРОИЗВЕД применяется в случаях, когда требуется перемножить много ячеек. Например, формула =ПРОИЗВЕД(A1:A3; C1:C3) эквивалентна произведению =A1 * A2 * A3 * C1 * C2 * C3.

 
evgen_softДата: Пятница, 06.11.2009, 17:21 | Сообщение # 12
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (vlad)
Прикрепления: 3975401.xls(112Kb)

vlad, спасибо посмотрел, есть вопрос: в формуле =СУММПРОИЗВ(--(ФИО=$B3);Площадь_S_2;процент_начесления_по_льготе)*Квартплата правильно ли я понимаю что зависимость идет только от столбца "процент_начесления_по_льготе" , а количество человек не учитывается?


Сообщение отредактировал evgen_soft - Пятница, 06.11.2009, 17:22
 
evgen_softДата: Пятница, 06.11.2009, 17:23 | Сообщение # 13
Группа: Проверенные
Сообщений: 12
Статус: Offline
DIM5955,
Спасибо прочитал, ознакомился
 
evgen_softДата: Пятница, 06.11.2009, 18:06 | Сообщение # 14
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (evgen_soft)
Quote (vlad)Прикрепления: 3975401.xls(112Kb) vlad, спасибо посмотрел, есть вопрос: в формуле =СУММПРОИЗВ(--(ФИО=$B3);Площадь_S_2;процент_начесления_по_льготе)*Квартплата правильно ли я понимаю что зависимость идет только от столбца "процент_начесления_по_льготе" , а количество человек не учитывается?

Посмотрел проверил, получается что при оплате, грубо, 4 чкловек- 1 имеет льготу в 50%, то в расчетах грубо все делется по полам, а если 2 льготника, то ни чего не происходит :(

 
DV68Дата: Пятница, 06.11.2009, 20:33 | Сообщение # 15
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если льгота зависит от двух ячеек, то формула льготы:
=1-ЕСЛИ($I2*$J2>1;1;$I2*$J2)
 
vladДата: Суббота, 07.11.2009, 01:02 | Сообщение # 16
Группа: Модераторы
Сообщений: 720
Статус: Offline
Quote (evgen_soft)
Посмотрел проверил, получается что при оплате, грубо, 4 чкловек- 1 имеет льготу в 50%, то в расчетах грубо все делется по полам, а если 2 льготника, то ни чего не происходит

Надо было сразу указать алгоритм начисления платежей(ведь не каждый может въехать в чужие таблицы)
Проверте файл во вложении.
Прикрепления: 3975401_1.xls(142.5 Kb)
 
evgen_softДата: Суббота, 07.11.2009, 02:25 | Сообщение # 17
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (vlad)
Надо было сразу указать алгоритм начисления платежей(ведь не каждый может въехать в чужие таблицы) Проверте файл во вложении.

bw Ломаю голову но перенести не могу, В ячейке H3 Ваша формула, по моему idontnow help В чем секрет?
Во вложении версия которая будет окончательная, но с Вашим дополнением
Прикрепления: 091106.xls(97.5 Kb)


Сообщение отредактировал evgen_soft - Суббота, 07.11.2009, 02:29
 
vladДата: Суббота, 07.11.2009, 11:53 | Сообщение # 18
Группа: Модераторы
Сообщений: 720
Статус: Offline
Естественно не будет работать. Выже нигде не указали что у вас все должно быть на одном листе , а сейчас пытаетесь склеить 2-а листа в один(но формулы не обманешь) .
Появится время посмотрю ,что сделать чтобы на 1-н лист все скомпоновать(ну или пользуйтесь вариантом с 2-я листами, как в первоисходнике).
 
DV68Дата: Суббота, 07.11.2009, 13:35 | Сообщение # 19
Группа: Модераторы
Сообщений: 648
Статус: Offline
Формулу =ЕСЛИ(C4>0;ЕСЛИ((СЦЕПИТЬ(C4;D4))>0;(ОКРУГЛ(СУММ(H4:O4);2));"");"")
можно заменить на
=ЕСЛИ(СЧЁТЗ(C4:E4)=3;СУММ(H4:O4);"")
Я вот не могу понять порядок начисления по льготе. Т.е. если у двоих имеется льгота, то за комнату вообще не платят? Или от доли в оплате отнимается процент?


Сообщение отредактировал DIM5955 - Суббота, 07.11.2009, 14:24
 
evgen_softДата: Суббота, 07.11.2009, 13:59 | Сообщение # 20
Группа: Проверенные
Сообщений: 12
Статус: Offline
Quote (DIM5955)
Я вот не могу понять порядок начисления по льготе. Т.е. если у двоих имеется льгота, то за комнату вообще не платят? Или от доли в оплате отнимается процент?

от доли в оплате.
 
DV68Дата: Суббота, 07.11.2009, 14:25 | Сообщение # 21
Группа: Модераторы
Сообщений: 648
Статус: Offline
Тогда так:
Прикрепления: 091106-1.xls(97.5 Kb)
 
vladДата: Суббота, 07.11.2009, 15:30 | Сообщение # 22
Группа: Модераторы
Сообщений: 720
Статус: Offline
=ЕСЛИ(C3>0;Квартплата*E3*Льгота;"")
А где зависимость от кол-ва льготников.
Должно быть =квартплата*(площадь/кол-во жильцов)*(кол-во жильцов без льгот+кол-во жильцов по льготе* льготу)
 
DV68Дата: Суббота, 07.11.2009, 17:17 | Сообщение # 23
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (vlad)
А где зависимость от кол-ва льготников.

В смысле?


Сообщение отредактировал DIM5955 - Суббота, 07.11.2009, 18:42
 
DV68Дата: Суббота, 07.11.2009, 17:43 | Сообщение # 24
Группа: Модераторы
Сообщений: 648
Статус: Offline
Именованная формула для 3-й строки: Льгота=1-'Расчет квартплаты'!$F3*'Расчет квартплаты'!$G3/'Расчет квартплаты'!$D3
В моем понимании если живет три человека и у одного из них льгота, то она расчитывается так: плата(например 90 руб.) делится на кол-во проживающих (90/3=30), получаем долю каждого проживающего. Затем умножаем на кол-во имеющих льготу и на соответственно саму льготу (30*1*0,5=15). Получаем сумму по льготе или процент (15/90=16,667% или 0,16667). Можно из общей платы вычесть льготу (90-15=75), но можно и сделать так (1- 0,16667= 0,83333) => (90*0.83333 = 75), что я и реализовал в своей формуле. Немного сумбурно, но надеюсь понятно объяснил.


Сообщение отредактировал DIM5955 - Суббота, 07.11.2009, 18:41
 
vladДата: Суббота, 07.11.2009, 18:28 | Сообщение # 25
Группа: Модераторы
Сообщений: 720
Статус: Offline
Quote (vlad)
=ЕСЛИ(C3>0;Квартплата*E3*Льгота;"")

Все нормально. Не обратил внимание на формулу "льгота". bw Подумал сначала , что это именованный диапазон со льготами(сам в первый раз допустил такой трабл). shuffle
 
DV68Дата: Суббота, 07.11.2009, 18:40 | Сообщение # 26
Группа: Модераторы
Сообщений: 648
Статус: Offline
 
evgen_softДата: Суббота, 07.11.2009, 21:25 | Сообщение # 27
Группа: Проверенные
Сообщений: 12
Статус: Offline
bw Честно говоря господа я совсем запутался, так мы оставляем
Quote (DIM5955)
Тогда так:
Прикрепления: 091106-1.xls(98Kb)
?
 
vladДата: Суббота, 07.11.2009, 23:16 | Сообщение # 28
Группа: Модераторы
Сообщений: 720
Статус: Offline
Quote (evgen_soft)
Честно говоря господа я совсем запутался, так мы оставляем

Так выбирайте вы сами. Алгоритм подсчета реализован схоже.
 
evgen_softДата: Воскресенье, 08.11.2009, 03:20 | Сообщение # 29
Группа: Проверенные
Сообщений: 12
Статус: Offline
vlad, DIM5955,

Спасибо большое и
Единственно, если я этот файл скопирую еще три раза, все функции должны же остаться?

 
DV68Дата: Воскресенье, 08.11.2009, 04:26 | Сообщение # 30
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (evgen_soft)
Единственно, если я этот файл скопирую еще три раза, все функции должны же остаться?

Я думаю это легко проверить на практике.
Можно использовать "Сохранить как..."



Сообщение отредактировал DIM5955 - Воскресенье, 08.11.2009, 07:35
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Расчет
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz