Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 2 из 8
  • «
  • 1
  • 2
  • 3
  • 4
  • 7
  • 8
  • »
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Архив вопросов
Архив вопросов
fdmДата: Среда, 21.01.2009, 08:28 | Сообщение # 31
Группа: Пользователи
Сообщений: 4
Статус: Offline
Мой ответ, файл выше не смог скачать.
Это касается халериков.
Прикрепления: 1867867.xls(13.5 Kb)


Уверенный ламер

Сообщение отредактировал fdm - Пятница, 23.05.2008, 17:57
 
AuthorДата: Среда, 21.01.2009, 08:28 | Сообщение # 32
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
по холерикам-меланхоликам решение такое:
в I7:L7
холерик сангвиник меланхолик флегматик

в E12:E21
8
9
8
12
8
10
12
8
9
8

в F12:F21
10
12
12
12
12
10
10
8
8
9

в G12:G21 формулы, которые выводят одно из 4-х значений, если выполняются заданные условия:
=ЕСЛИ(И(E12>10;F12>10);$I$7;ЕСЛИ(И(E12>10;F12<=10);$J$7;ЕСЛИ(И(E12<=10;F12>10);$K$7;ЕСЛИ(И(E12<=10;F12<=10);$L$7;"никто"))))
=ЕСЛИ(И(E13>10;F13>10);$I$7;ЕСЛИ(И(E13>10;F13<=10);$J$7;ЕСЛИ(И(E13<=10;F13>10);$K$7;ЕСЛИ(И(E13<=10;F13<=10);$L$7;"никто"))))
=ЕСЛИ(И(E14>10;F14>10);$I$7;ЕСЛИ(И(E14>10;F14<=10);$J$7;ЕСЛИ(И(E14<=10;F14>10);$K$7;ЕСЛИ(И(E14<=10;F14<=10);$L$7;"никто"))))
=ЕСЛИ(И(E15>10;F15>10);$I$7;ЕСЛИ(И(E15>10;F15<=10);$J$7;ЕСЛИ(И(E15<=10;F15>10);$K$7;ЕСЛИ(И(E15<=10;F15<=10);$L$7;"никто"))))
=ЕСЛИ(И(E16>10;F16>10);$I$7;ЕСЛИ(И(E16>10;F16<=10);$J$7;ЕСЛИ(И(E16<=10;F16>10);$K$7;ЕСЛИ(И(E16<=10;F16<=10);$L$7;"никто"))))
=ЕСЛИ(И(E17>10;F17>10);$I$7;ЕСЛИ(И(E17>10;F17<=10);$J$7;ЕСЛИ(И(E17<=10;F17>10);$K$7;ЕСЛИ(И(E17<=10;F17<=10);$L$7;"никто"))))
=ЕСЛИ(И(E18>10;F18>10);$I$7;ЕСЛИ(И(E18>10;F18<=10);$J$7;ЕСЛИ(И(E18<=10;F18>10);$K$7;ЕСЛИ(И(E18<=10;F18<=10);$L$7;"никто"))))
=ЕСЛИ(И(E19>10;F19>10);$I$7;ЕСЛИ(И(E19>10;F19<=10);$J$7;ЕСЛИ(И(E19<=10;F19>10);$K$7;ЕСЛИ(И(E19<=10;F19<=10);$L$7;"никто"))))
=ЕСЛИ(И(E20>10;F20>10);$I$7;ЕСЛИ(И(E20>10;F20<=10);$J$7;ЕСЛИ(И(E20<=10;F20>10);$K$7;ЕСЛИ(И(E20<=10;F20<=10);$L$7;"никто"))))
=ЕСЛИ(И(E21>10;F21>10);$I$7;ЕСЛИ(И(E21>10;F21<=10);$J$7;ЕСЛИ(И(E21<=10;F21>10);$K$7;ЕСЛИ(И(E21<=10;F21<=10);$L$7;"никто"))))



Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
AuthorДата: Среда, 21.01.2009, 08:28 | Сообщение # 33
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Quote (bublik)
Спасибо,
всё получилось.
Не знал что такое формула массива, не сразу понял.
Но, работает если, нет в столбце пустых ячеек и ячеек только, с буквенными значениями.
Т.е. в таком виде, выдаёт ошибку.
11,5н


Пр-кт
11,5у
Б/Л
#значен!

вот так будет корректно работать и для приведенного случая:

=СУММ(ЕСЛИ(ЕЧИСЛО(ЗНАЧЕН(ЛЕВСИМВ(B5:B9;ДЛСТР(B5:B9)-1)));ЗНАЧЕН(ЛЕВСИМВ(B5:B9;ДЛСТР(B5:B9)-1))))
тоже вводить как формулу масива



Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
Tuch-kaДата: Среда, 21.01.2009, 08:28 | Сообщение # 34
Группа: Пользователи
Сообщений: 2
Статус: Offline
to Author
Спасибо огромное happy hands , вы зе бест!!! Кроме вас никто не смог biggrin respect
 
judge_armДата: Среда, 21.01.2009, 08:29 | Сообщение # 35
Группа: Пользователи
Сообщений: 2
Статус: Offline
У меня такая проблема. Есть файл с тремя письмами. На третьем письме есть табличка, которую нужно отобразить на первом листе, типа как вставляется обект из файла. То есть, чтобы эта табличка отобразилась поверх всех окон?
 
AuthorДата: Среда, 21.01.2009, 08:29 | Сообщение # 36
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Quote (judge_arm)
У меня такая проблема. Есть файл с тремя письмами. На третьем письме есть табличка, которую нужно отобразить на первом листе, типа как вставляется обект из файла. То есть, чтобы эта табличка отобразилась поверх всех окон?

Речь идет о файле Excel?
Что значит "с тремя письмами"? Что значит "поверх всех оконо"?


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
judge_armДата: Среда, 21.01.2009, 08:29 | Сообщение # 37
Группа: Пользователи
Сообщений: 2
Статус: Offline

Да, это файл Excel! На Лист1 вставлено Окно1 с другого файла. Мне нужно вставить с вкладки Лист3 в Лист1. Как это сделать?

 
bostanДата: Среда, 21.01.2009, 08:29 | Сообщение # 38
Группа: Пользователи
Сообщений: 4
Статус: Offline
Здравствуйте!
имею такой вопрос: есть ряд ячеек с целыми числовыми значениями в строке, к примеру диапазон A2:F2,
нужно задать формулу, которая будет выдавать количество чисел из этого массива(A2:F2), кратных к примеру числу 3,4,5,6 и 7.
Какая должна быть формула для каждого из чисел(3,4,5,6,7)? Спасибо.
Прикрепления: Excel.xls(20.5 Kb)
 
bublikДата: Среда, 21.01.2009, 08:29 | Сообщение # 39
Продвинутый
Группа: Проверенные
Сообщений: 21
Статус: Offline
Cпасибо, то что, доктор прописал biggrin
 
AuthorДата: Среда, 21.01.2009, 08:29 | Сообщение # 40
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Quote (bostan)
нужно задать формулу, которая будет выдавать количество чисел из этого массива(A2:F2), кратных к примеру числу 3,4,5,6 и 7.
Какая должна быть формула для каждого из чисел(3,4,5,6,7)? Спасибо.

Ответ в файле.

Очевидно, что вместо ссылки на ячейку, можно указывать и само число. То есть, например, вместо ячейки (G4) в формуле =СУММ(ЕСЛИ(ОСТАТ($A$2:$F$2;G4)=0;1;)), можно указать 3 (тройку), то есть, в этом случае формула примет вид: =СУММ(ЕСЛИ(ОСТАТ($A$2:$F$2;3)=0;1;)). Однако, в этом случае формулу нельзя растягивать. Придется вводить (или редактировать) каждую формулу отдельно.
Важное замечание: формулы вводятся как формулы массива, то есть после ввода формулы необходимо одновременное нажать Ctrl+Shift+Enter

Прикрепления: Excel_otvet.xls(32.5 Kb)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
bostanДата: Среда, 21.01.2009, 08:30 | Сообщение # 41
Группа: Пользователи
Сообщений: 4
Статус: Offline
Quote (Author)
Ответ в файле.

благодарю, буду тестить. wink

 
bublikДата: Среда, 21.01.2009, 08:30 | Сообщение # 42
Продвинутый
Группа: Проверенные
Сообщений: 21
Статус: Offline
Здравствуйте!
Не могу найти и не знаю, можно ли в excel активировать опцию которая, бы отражала имя пользователя изменившего данные в соседней ячейке?
Общий доступ к книге отражает только, коменты.
Спасибо.
 
shac-olegДата: Среда, 21.01.2009, 08:30 | Сообщение # 43
Группа: Пользователи
Сообщений: 3
Статус: Offline
есть день рождения ребенка. есть сегодняшнее число. необходимо выбрать возрастную группу: возраст ребенка плю-минус еще полгода.
пример: ребенку 01.06.2008 исполнилось 18 лет. если сегодняшнее число будет в интервале от 01.01.2008 (т.е. минус полгода от дня рожения) до 31.12.2008 (т.е. плюс полгода от дня рожения) он входит в группу 18-летних. Однако: если сегодняшнее число будет в интервале от 01.01.2009 (т.е. минус полгода от дня рожения) до 31.12.2009 (т.е. плюс полгода от дня рожения) он входит в группу 19-летних.


Спасибо тем, кто меня любит - Вы делаете меня лучше!
Спасибо тем, кто меня ненавидит - Вы делаете меня сильнее!
Спасибо тем, кому вообще всё равно - Вы служите для массовки!
 
AuthorДата: Среда, 21.01.2009, 08:30 | Сообщение # 44
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
shac-oleg, уточняющие вопросы:
1. сколько возрастных групп? (перечислите все)
2. что должна возвращать формула? (номер возрастной группы, название возрастной группы, что-то другое)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
AuthorДата: Среда, 21.01.2009, 08:30 | Сообщение # 45
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Quote (bublik)
Здравствуйте!
Не могу найти и не знаю, можно ли в excel активировать опцию которая, бы отражала имя пользователя изменившего данные в соседней ячейке?
Общий доступ к книге отражает только, коменты.
Спасибо.

К сожалению, мы не готовы сейчас дать Вам ответ на этот вопрос. Есть подозрение, что то, что Вам хочется, возможно реализовать только с помощью макросов.


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
AuthorДата: Среда, 21.01.2009, 08:30 | Сообщение # 46
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
shac-oleg, посмотрите. возможно, это то, что Вам надо.
Если нет, просим уточнить вопрос.
Формула в файле делает следующее: если до дня рождения осталось менее чем 182 дня, то человек считается на год старше.
Прикрепления: vozrast_gr.xls(23.5 Kb)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
bublikДата: Среда, 21.01.2009, 08:31 | Сообщение # 47
Продвинутый
Группа: Проверенные
Сообщений: 21
Статус: Offline
Спасибо, будем искать.
 
NastenaMirДата: Среда, 21.01.2009, 08:31 | Сообщение # 48
Группа: Пользователи
Сообщений: 8
Статус: Offline
Quote (Sidorov)
1.Как посчитать кол-во одинаковых слов в столбце?

Добрый день!
Мне тоже нужен ответ на этот вопрос, к сожалению, не нашла ниже ответа.
У меня анкетные данные, в одних столбцах только числа (могут быть через запятую), в других только слова - тоже просто через запятую перечислены.
Нужно просто посчитать повторения в столбцах.
Раньше как-то делала-забыла как sad Результатом помню было в скобочках рядом со словом количество упоминаний в столбце.
 
AuthorДата: Среда, 21.01.2009, 08:31 | Сообщение # 49
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
NastenaMir,
можете ли Вы выложить пример?


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
NastenaMirДата: Среда, 21.01.2009, 08:31 | Сообщение # 50
Группа: Пользователи
Сообщений: 8
Статус: Offline
Quote (Author)
NastenaMir, можете ли Вы выложить пример?

Да, конечно
Прикрепления: 9139004.xls(27.5 Kb)
 
AuthorДата: Среда, 21.01.2009, 08:31 | Сообщение # 51
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
NastenaMir,
Ответ в файле. Надеемся, что Ваш вопрос понят правильно.
Прикрепления: unik.xls(35.5 Kb)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
NastenaMirДата: Среда, 21.01.2009, 08:31 | Сообщение # 52
Группа: Пользователи
Сообщений: 8
Статус: Offline
Немного не то no
Но все равно спасибо!
 
AuthorДата: Среда, 21.01.2009, 08:32 | Сообщение # 53
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Quote (NastenaMir)
Немного не то
Но все равно спасибо!

Если "немного не то", но вопрос для Вас еще актуален, просим уточнить Ваш вопрос, возможно, мы все-таки поможем Вам


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
NastenaMirДата: Среда, 21.01.2009, 08:32 | Сообщение # 54
Группа: Пользователи
Сообщений: 8
Статус: Offline
День добрый!
Вопрос актуален, нужно сосчитать, сколько раз в столбце повторяется значение. С числами в столбцах разобралась с помощью простой формулы СЧЕТЕСЛИ. Остались слова и числа, которые перечислены через запятую. В идеале должно получиться:
Слово 1 - 1раз
Слово 2 - 7 раз и т.д.
Число 1 - 8 раз
Число 2 - 10 раз и т.д.
Беда в том, что слово или число может быть, как одно в ячейке (тогда все просто), а может и несколько через запятую.
Вот бы их оттуда выделить и тоже сосчитать...
 
AuthorДата: Среда, 21.01.2009, 08:32 | Сообщение # 55
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
Quote (NastenaMir)
День добрый!
Вопрос актуален, нужно сосчитать, сколько раз в столбце повторяется значение. С числами в столбцах разобралась с помощью простой формулы СЧЕТЕСЛИ. Остались слова и числа, которые перечислены через запятую. В идеале должно получиться:
Слово 1 - 1раз
Слово 2 - 7 раз и т.д.
Число 1 - 8 раз
Число 2 - 10 раз и т.д.
Беда в том, что слово или число может быть, как одно в ячейке (тогда все просто), а может и несколько через запятую.
Вот бы их оттуда выделить и тоже сосчитать...

И снова просим пример, так и нам и Вам будет легче (нам - подготовить ответ, Вам - понять, как это работает)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
NastenaMirДата: Среда, 21.01.2009, 08:32 | Сообщение # 56
Группа: Пользователи
Сообщений: 8
Статус: Offline
Пример все тот же
Прикрепления: Anketa.xls(41.0 Kb)
 
AuthorДата: Среда, 21.01.2009, 08:32 | Сообщение # 57
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
а где перечень слов, которые нужно подсчитать?
что мы относим к "Слово 1", "Слово 2" и т.д.? то же самое и по числам...


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
NastenaMirДата: Среда, 21.01.2009, 08:32 | Сообщение # 58
Группа: Пользователи
Сообщений: 8
Статус: Offline
Нужно посчитать все слова и числа из столбцов F, G, то есть сколько раз в столбце встречается каждое из них.
 
AuthorДата: Среда, 21.01.2009, 08:33 | Сообщение # 59
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
выложите список слов


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
NastenaMirДата: Среда, 21.01.2009, 08:33 | Сообщение # 60
Группа: Пользователи
Сообщений: 8
Статус: Offline
Вот, пожалуйста. Только в следующем месяце список может поменяться
Прикрепления: Slova.xls(12.0 Kb)
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Архив вопросов
  • Страница 2 из 8
  • «
  • 1
  • 2
  • 3
  • 4
  • 7
  • 8
  • »
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz