Новые сообщения · Участники · Правила форума · Поиск · RSS
  • Страница 1 из 1
  • 1
Модератор форума: DV68, Author  
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » проверка вводимого значения
проверка вводимого значения
КатеринаДата: Среда, 10.12.2008, 18:10 | Сообщение # 1
Группа: Пользователи
Сообщений: 3
Статус: Offline
ситуация. wacko
существует столбец с различными значениями, который периодически пополняется новыми данными. каждое значение оригинально и неповторимо. задача: автоматизировать проверку, при вводе каждого нового значения, на наличие идентичных значений. просто не допускать ввода значения идентичного уже имеющемуся в списке.
Прикрепления: MicrosoftOffice.xlsx(27.5 Kb)


Сообщение отредактировал Катерина - Среда, 10.12.2008, 18:17
 
sizopДата: Среда, 10.12.2008, 20:54 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1801
Статус: Offline
Катерина, файл в формате офиса 2008? biggrin ну нельзя же так над людьми издеваться, это мне надо офис 2008 установить сохранить файл в нормальном формате, а потом удалить офис 2008
 
AuthorДата: Четверг, 11.12.2008, 12:59 | Сообщение # 3
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
да, желательно приложить файл, хотя бы в формате Excel 2003


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
КатеринаДата: Четверг, 11.12.2008, 14:21 | Сообщение # 4
Группа: Пользователи
Сообщений: 3
Статус: Offline
покорнейше прошу простить. запамятовала happy
Прикрепления: 0317082.xls(49.5 Kb)
 
AuthorДата: Пятница, 12.12.2008, 13:02 | Сообщение # 5
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline
по нашему мнению, лучше всего это сделать через условное форматирование.
Для этого находясь в A2 выделите ячейки с A2 и по длине предполагаемого списка (сейчас сделано до A177) зайдите: Формат-Условное форматирование, выберите "формула" и введите такую формулу: =СЧЁТЕСЛИ($A$2:A2;A2)>1 и задайте нужное форматирование (сейчас задано цвет заливки - красный) и нажмите "Ок".
Т.о. в случае, если в ячейку будет введено название, которое уже имеется выше, цвет заливки этой ячейки станет красным. Для примера в A51 введено уже имеющееся значение APB7XY8000069.
Прикрепления: 0317082_resh.xls(56.0 Kb)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
КатеринаДата: Понедельник, 15.12.2008, 14:12 | Сообщение # 6
Группа: Пользователи
Сообщений: 3
Статус: Offline
спасибо большое!!!!! очень выручили дельным советом smile
 
vladДата: Воскресенье, 02.08.2009, 16:30 | Сообщение # 7
Группа: Модераторы
Сообщений: 720
Статус: Offline
Можно еще через "Данные-проверка".
Прикрепления: 0317082_resh.rar(6.7 Kb)
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » проверка вводимого значения
  • Страница 1 из 1
  • 1
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2019 Используются технологии uCoz