Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: Author 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 01.10.09 (Суммировать десять наибольших значений)
01.10.09
AuthorДата: Четверг, 01.10.2009, 20:05 | Сообщение # 1
Гуру
Группа: Администраторы
Сообщений: 187
Статус: Offline

Суммировать десять наибольших значений

Название: Как с помощью одной формулы просуммировать 10 наибольших значений

Формула с помощью которой можно просуммировать 10 наибольших значений диапазона использует две функции Excel: это функция СУММ() и функция НАИБОЛЬШИЙ(). Однако такая формула должна быть введена как формула массива (то есть одновременным нажатием клавиш Ctrl Shift Enter)

Итак, формула:

Формула

=СУММ(НАИБОЛЬШИЙ(B6:B30;{1;2;3;4;5;6;7;8;9;10}))

Комментарий к формуле:
Если формула введена правильно, то есть с использованием трех одновременно нажатих клавиш (Ctrl+Shift+Enter), то после ввода она должна выглядеть так:
{=СУММ(НАИБОЛЬШИЙ(B6:B30;{1;2;3;4;5;6;7;8;9;10}))}
то есть формула, как бы "обрамлена" в фигурные скобки.

Файл-пример можно скачать по ссылке

Примечание
Можно получить требуемый результат (сумму первых десяти наибольших регионов) и без помощи формулы. Для этого нужно воспользоваться сортировкой, а также ...
Как это можно сделать Вы сможете увидеть в видео, которое будет подготовлено к следующему выпуску рассылки.

Сочетание клавиш в Excel: присвоить числовой формат с двумя знаками после запятой и разделителем разряда

Как отформатировать число, чтобы было 2 знака после запятой и разделитель разрядов
Допустим, у Вас в ячейке хранятся числовые данные, например: 105324. Когда нет визуальных разделителей разрядов, то такие числа плохо воспринимаются зрительно.
Намного проще воспринимать число вида 105 324,00, не так ли?
Создатели Excel позаботились о том, чтобы присвоить формату чисел в котором "точность до сотых, разделитель тысяч и знак минус перед отрицательными значениями" определенное сочетание клавиш.
Вот оно: Ctrl+Shift+! (одновременно нажатие этих трех клавиш).
Уверены, что это сочетание во многих случаях сэкономит Ваше время на форматирование числовым форматом с разделителями и двумя знаками после запятой (обычно этот формат применяется для отображения числовых данных о денежных суммах).

Полезная ссылка на книги об Excel...

На сайте рассылки теперь доступна одна из книг общепризнанного гуру Excel Джона Уокенбаха. Книга посвящена формулам в Excel, однако, Вы найдете там не только очень подробное описание многих полезных формул, в книге Вы также найдете массу и другой полезной информации. Кроме самой книги Вам будут доступны и файлы-примеры, которые поставляются на диске с этой книгой. Кстати, рассмотренная в этой рассылке формула также есть в этой книге.


От вашей активности зависит когда в следующий раз Вы получите рассылку.
Минимальная активность - не очень скоро, максимальная - уже на следующей неделе.

Поддержать проект Excel - готовые формулы!


Адрес excel-ok@yandex.ru ждет твой экселевский файл. Мы поможем тебе разобраться!
ПРИГЛАШАЕМ заинтересованных лиц размещать информацию рекламного характера в нашей рассылке.
На момент выхода этого выпуска на рассылку подписано более 4 200 чел.

Файл к выпуску от 01.10.09
Прикрепления: summ_naibolsh.xls(20Kb)


Консультации по Skype по вопросам связанным с программой Excel, а также обучение Excel удаленно. Сайт: excelskype.ru
 
Форум » ТЕМАТИЧЕСКИЕ » Архив рассылки "Excel - готовые формулы" » 01.10.09 (Суммировать десять наибольших значений)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz