Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Выборка до наступления определенных условий (Выборка до тех пор пока значение истина)
Выборка до наступления определенных условий
PritulaДата: Воскресенье, 21.10.2012, 01:29 | Сообщение # 1
Группа: Пользователи
Сообщений: 5
Статус: Offline
в Ячейке E5 нужно соорудить формулу Выбирать значение Е4 из диапозона А2:А11 до тех пор пока значение Истина. Например. Значение Е4 больше 100? ДА=Истина. Далее, значение Е4 больше 200? Да= истина. Далее Значение Е4 больше 300 Да = истина. Значение У4 больше 400? НЕТ-ЛОЖЬ! ТОгда в ячейке Е5 отображено значение столбца B находящегося в одном ряду со значением 400. Если в данном диапазоне условие не выполняется то значение Е5=0
Прикрепления: _Microsoft_Exce.xls(26Kb)


Сообщение отредактировал Pritula - Воскресенье, 21.10.2012, 02:06
 
DV68Дата: Воскресенье, 21.10.2012, 11:35 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Пробуте так:
Code
=ЕСЛИ(E4<A2;B2;ПРОСМОТР(E4;A2:A11;B3:B12))
 
PritulaДата: Воскресенье, 21.10.2012, 21:45 | Сообщение # 3
Группа: Пользователи
Сообщений: 5
Статус: Offline
Огромное человеческое спасибо! Все отлично работает! СПАСИБО! up up up
 
PritulaДата: Понедельник, 22.10.2012, 03:24 | Сообщение # 4
Группа: Пользователи
Сообщений: 5
Статус: Offline
Хочу уточнить 1 момент. Как правильно записать формулу, если нужно учесть три или более ЕСЛИ? например, ЕСЛИ H1=5, тогда K1="Желтый", Если H1=4, тогда K1="Красный", Если H1=3, тогда K1="Синий". help
 
PritulaДата: Понедельник, 22.10.2012, 03:47 | Сообщение # 5
Группа: Пользователи
Сообщений: 5
Статус: Offline
Ложная тревога! )) Разобрался )) Делается с помощью вложенных ЕСЛИ. Например
Code
=ЕСЛИ(H1=5;"Желтый";ЕСЛИ(И(H1=4);"Красный";ЕСЛИ(И(H1=3);"Синий";"")))
 
Serge_007Дата: Понедельник, 22.10.2012, 12:29 | Сообщение # 6
Группа: Проверенные
Сообщений: 468
Статус: Offline
И - лишнее
Code
=ЕСЛИ(H1=5;"Желтый";ЕСЛИ(H1=4;"Красный";ЕСЛИ(H1=3;"Синий";"")))


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
PritulaДата: Вторник, 23.10.2012, 03:31 | Сообщение # 7
Группа: Пользователи
Сообщений: 5
Статус: Offline
Спасибо! up up up
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Выборка до наступления определенных условий (Выборка до тех пор пока значение истина)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz