Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » поиск не полностью совпадающих значений в разных списках (списки разные по кол-ву строк)
поиск не полностью совпадающих значений в разных списках
catДата: Понедельник, 30.07.2012, 14:29 | Сообщение # 1
Группа: Пользователи
Сообщений: 7
Статус: Offline
Помогите пожалуйста,тема такая: есть два листа с данными( пример во вложении).Мне нужно в ЛИСТЕ2 сравнить название фирмы с листом 1( при том, что в листе 1 оно без кавычек, или капс локом-короче как попало), а потом подтянуть адрес из ЛИСТА2-опять же, не весь, а только город в ЛИСТ1.
Заранее спасибо всем за советы!
Прикрепления: 4292119.xlsx(11Kb)
 
Serge_007Дата: Понедельник, 30.07.2012, 15:34 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
.
Прикрепления: cat.xls(29Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
catДата: Понедельник, 30.07.2012, 16:21 | Сообщение # 3
Группа: Пользователи
Сообщений: 7
Статус: Offline
Спасибо!А нельзя сделать так, чтобы формула выдирала только название города?
 
Serge_007Дата: Понедельник, 30.07.2012, 16:38 | Сообщение # 4
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (cat)
формула выдирала

Ну и выраженьица у Вас :)

Code
=ИНДЕКС(ПСТР(Лист2!B$1:B$11;НАЙТИ(",";Лист2!B$1:B$11)+1;НАЙТИ(",";Лист2!B$1:B$11;НАЙТИ(",";Лист2!B$1:B$11)+1)-НАЙТИ(",";Лист2!B$1:B$11)-1);ЕСЛИ(СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(A2;Лист2!A$1:A$11))*СТРОКА($1:$11))>0;СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(A2;Лист2!A$1:A$11))*СТРОКА($1:$11));""))
Прикрепления: cat2.xls(30Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » поиск не полностью совпадающих значений в разных списках (списки разные по кол-ву строк)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz