Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помгите пожалуйста со сложной задачей (Сумирование по датам со временем от и до)
Помгите пожалуйста со сложной задачей
acheslavДата: Вторник, 22.05.2012, 23:51 | Сообщение # 1
Группа: Пользователи
Сообщений: 2
Статус: Offline
Есть сводная таблица в которой есть продажи по дате со временем, нужно суммировать товар с заданным диапозоном по дате со временем, т.е. с 1.05.2012 00:00 до 1.05.2012 09:00
На примере будет понятнее
Прикрепления: 0380333.xls(26Kb)


Сообщение отредактировал acheslav - Вторник, 22.05.2012, 23:59
 
DV68Дата: Среда, 23.05.2012, 02:45 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Так:
Code
=СУММЕСЛИ($I$3:$I$8;">"&$A3;J$3:J$8)-СУММЕСЛИ($I$3:$I$8;">"&$B3;J$3:J$8)

или так:
Code
=СУММПРОИЗВ(($I$3:$I$8>$A3)*($I$3:$I$8<$B3);J$3:J$8)
 
acheslavДата: Четверг, 24.05.2012, 23:12 | Сообщение # 3
Группа: Пользователи
Сообщений: 2
Статус: Offline
Quote (DV68)
Так: Code=СУММЕСЛИ($I$3:$I$8;">"&$A3;J$3:J$8)-СУММЕСЛИ($I$3:$I$8;">"&$B3;J$3:J$8) или так: Code=СУММПРОИЗВ(($I$3:$I$8>$A3)*($I$3:$I$8<$B3);J$3:J$8)


Спасибо
Code
=СУММПРОИЗВ(($I$3:$I$46>A3)*($I$3:$I$46<B3)*($J$3:$J$46<>0)*($J$3:$J$46))
я дошёл до более сложного
 
DV68Дата: Пятница, 25.05.2012, 02:49 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote
($J$3:$J$46<>0)

лишнее условие
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Помгите пожалуйста со сложной задачей (Сумирование по датам со временем от и до)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz