Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Использование "или" в формуле Суммпроизв
Использование "или" в формуле Суммпроизв
Andre_wwwДата: Четверг, 29.03.2012, 13:25 | Сообщение # 1
Группа: Пользователи
Сообщений: 1
Статус: Offline
Помогите пожалуста с дилемой:
Использовал всегда формулу "Суммпроизв" для выборки данных соответствующих условиям, но задача усложнилась и теперь условий стало несколько, причем выборка должна производиться по совпадению одного из условий и не повторятся. То есть, если значение соответствовало условию1, то при соответствии условию2 оно не должно дублироваться. Предполагаю, что "Суммпроизв" не поможет в моем случае, но никак не могу определить какая функция мне подойдет, перебрал уже несколько (суммесли и суммеслимн), но проблема как была так и осталась.
Чтоб было понятнее набросал пример расчета в прикрипленном файле.

PS: обратите внимание, что в главной таблице не зря было введено значение "глинаа", а в таблице критериев "глина", это для того чтоб проверить выбирает ли он по принципу "и" или по принципу "или".

Буду очень благодарен за помощь.
Прикрепления: 9284085.xls(25Kb)
 
DV68Дата: Четверг, 29.03.2012, 15:41 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Формула массива (одновременно Ctrl+Shift+Enter):
Code
=СУММ(ЕСЛИ((A2:A10=G11:K11)+(B2:B10=G12:K12);C2:C10))


или
Code
=СУММПРОИЗВ(((A2:A10=G11:K11)+(B2:B10=G12:K12)>0)*C2:C10)
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Использование "или" в формуле Суммпроизв
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz