Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » назначение уникальной формулы
назначение уникальной формулы
vvpДата: Вторник, 01.11.2011, 18:07 | Сообщение # 1
Группа: Проверенные
Сообщений: 16
Статус: Offline
Помогите расшифровать формулу. Файл приложить не могу, т.к. это в книге, которую можно назвать сводной, итоговой и т.п. со множестовом листов и сведениями для не публичного просмотра.
Есть формула (функция) =ЕСЛИ($B25=1; ДВССЫЛ(СЦЕПИТЬ($A$21;"!";"H";СТРОКА('2009'!H11)));),
не пойму назначение функций в конце формулы, а именно {..."!";"H";СТРОКА('2009'!H11}, которая присутствует в каждой ячейке книги, но не участвуют в расчетах, и удалить нельзя, т.к. отображается #СЫЛКА!.

Заранее благодарю.
 
Serge_007Дата: Вторник, 01.11.2011, 18:39 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (vvp)
СТРОКА('2009'!H11)

возвращает число 11 (см. справку по этой функции).

ЗЫ Кстати, формулу можно немного сократить:
Code
=ЕСЛИ($B25=1;ДВССЫЛ($A$21&"!H"&СТРОКА(A11));)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Serge_007Дата: Вторник, 01.11.2011, 19:34 | Сообщение # 3
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Serge_007)
формулу можно немного сократить

Code
=ЕСЛИ($B25;ДВССЫЛ($A$21&"!H"&СТРОКА(A11));)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
vvpДата: Вторник, 01.11.2011, 19:47 | Сообщение # 4
Группа: Проверенные
Сообщений: 16
Статус: Offline
СПАСИБО, работает.
Может сможете мне еще помочь, необходимо в ячейке собрать сумму данных, но с тех же листов, куда ссылется ячейка,=ЕСЛИ($B25=1;ДВССЫЛ($A$21&"!H"&СТРОКА(A11));) и при таком же условии: если $B25=1. пример (в текстовом виде) прилагаю.
Прикрепления: 4315462.xls(18Kb)


Сообщение отредактировал vvp - Вторник, 01.11.2011, 19:54
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » назначение уникальной формулы
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz