Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Проблема с условиями
Проблема с условиями
DilДата: Четверг, 01.09.2011, 04:11 | Сообщение # 1
Группа: Пользователи
Сообщений: 3
Статус: Offline
Добрый день, знатоки)

Нужно посчитать средневзвешенные (по Volume) месячные значения VC (см приложение)
Проблема в том, что сделать мне это нужно "красиво" без лишних столбцов с вспомогательными расчетами.

Как я вижу проблему: необходимо (B2*C2+B3*C3+...B93*C93)/Sum(B2:B93) для 2009-07, но это ручками. Задача в том, чтобы через весь массив формула автоматом отбирала ячейки, которые удовлетворяют условию (условие - конкретный месяц) для выполнения этих арифм. действий.

Заранее спасибо!
Прикрепления: Book1SZx.xls(85Kb)
 
DV68Дата: Четверг, 01.09.2011, 15:38 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Возможно так:
Code
=СУММПРОИЗВ((МЕСЯЦ(A2:A685)=7)*B2:B685*C2:C685)/СУММПРОИЗВ(СУММПРОИЗВ((МЕСЯЦ(A2:A685)=7)*C2:C685))
 
DilДата: Воскресенье, 04.09.2011, 23:03 | Сообщение # 3
Группа: Пользователи
Сообщений: 3
Статус: Offline
Спасибо!
практически то, что было нужно.
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Проблема с условиями
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz