Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » курс валют (если чет в двух валютах и более)
курс валют (если чет в двух валютах и более)
АннаДоляДата: Четверг, 14.07.2011, 17:03 | Сообщение # 1
Группа: Проверенные
Сообщений: 15
Статус: Offline
Вопрос, вот в чем - у меня есть таблица. В первом листе, которой введется отслеживание оплат от клиентов
- в ней указаны-дата платежа, сумма оплаты в грн и вид валюты (долар или евро), курс валюты.
на втором листе файла заносятся курсы валют на определенные даты.
Если бы валюта была одна, то для меня не было бы ничего страшнего. А так я не могу создать такую формулу, чтобы в первом листе таблицы в колонку курс валюты попадал бы вверный курс из второго листа, исходя из того в какой валюте платеж.
Дело в том, что отслеживать платежи в валюте стали только сейчас. А таблица курс валют у нас есть за весь данный год. просто хочется, чтобы не вручную сейчас набирать все курсы, исходя из дня платежа , а поставить формулу.
Пример файла прилагается.
И еще одно в моей таблице буту строчки где платежи еще не осуществились. можно ли сделать так, чтобы если в колонке - дата оплаты пусто. то и в колоне -курс валют, тоже было пусто.
Заранее спасибо!!!
Прикрепления: 5261617.xls(29Kb)


Сообщение отредактировал АннаДоля - Четверг, 14.07.2011, 17:12
 
DV68Дата: Четверг, 14.07.2011, 17:18 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Можно так:
C2:
Code
=ВПР(B2;'курс валют'!$A$2:$C$5;2+(A2="USD");0)
 
АннаДоляДата: Четверг, 14.07.2011, 18:44 | Сообщение # 3
Группа: Проверенные
Сообщений: 15
Статус: Offline
Большое спасибо! Все работает.
А можно ли. чтобы если не стоит дата оплаты. то курс валют не ставился бы (то есть чтобы в даной ячейки было пусто)
 
DV68Дата: Четверг, 14.07.2011, 19:38 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если Вы про ячейку В2, то так:
=ЕСЛИ(B2="";"";здесь основная формула)
А если про то, что нет дня в таблице на 2-м листе, то так:
=ЕСЛИ(ЕНД(ПОИСКПОЗ(B2;'курс валют'!$A$2:$A$5;0));"";здесь основная формула)
 
АннаДоляДата: Четверг, 14.07.2011, 19:54 | Сообщение # 5
Группа: Проверенные
Сообщений: 15
Статус: Offline
Извиняюсь, что не понятно описала проблему.
Ваша формула =ЕСЛИ(B2="";"";здесь основная формула) - как раз, то, что мне было нужно.
Большое Вам спасибо.
 
АннаДоляДата: Пятница, 15.07.2011, 20:32 | Сообщение # 6
Группа: Проверенные
Сообщений: 15
Статус: Offline
Здраствуйте. Помогите еще пожалуйста. Есть договора, в которых прописано, что размер оплаты в грнивнах определяется по курсу валюты на дату, что предшествует оплате.
Какую можно поставить формулу в первый лист в колоне курс валют, чтобы подтягивался курс на дату, которая предшествует оплате.
заранее спасибо.
 
DV68Дата: Пятница, 15.07.2011, 21:28 | Сообщение # 7
Группа: Модераторы
Сообщений: 648
Статус: Offline
Здравствуйте.
Просто отнимите 1 день от искомого и интервальный просмотр можно не ставить или 1:
Code
=ВПР(B3-1;'курс валют'!$A$2:$C$5;2+(A3="USD"))
 
АннаДоляДата: Понедельник, 18.07.2011, 12:16 | Сообщение # 8
Группа: Проверенные
Сообщений: 15
Статус: Offline
Спасибо
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » курс валют (если чет в двух валютах и более)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz