Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 2 из 2«12
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подскажите формулу или несколько формул "ЕСЛИ" или что то
Подскажите формулу или несколько формул "ЕСЛИ" или что то
kapitanДата: Пятница, 28.10.2011, 15:37 | Сообщение # 31
Группа: Проверенные
Сообщений: 11
Статус: Offline
Люди добрые!!! Подскажите пожалуйста, второй день бьюсь.
Есть некоторое постоянное множество данных
например: 5 10 20 50 100 500
и есть одна переменная Х, как записать формулу чтобы мне выдавалось число из множества максимальное, но не больше переменной Х.
Напрмер если Х=8, то 5
если Х=35 от 20, если Х=245 то 100.
Спасибо.
 
DV68Дата: Пятница, 28.10.2011, 16:05 | Сообщение # 32
Группа: Модераторы
Сообщений: 648
Статус: Offline
Можно по разному, например, если цифры идут по возрастанию:
Code
=ПРОСМОТР(C5;C3:H3)
 
kapitanДата: Пятница, 28.10.2011, 16:13 | Сообщение # 33
Группа: Проверенные
Сообщений: 11
Статус: Offline
Благодарствую, были бы рядом коньяк бы подарил.
 
kapitanДата: Пятница, 28.10.2011, 16:20 | Сообщение # 34
Группа: Проверенные
Сообщений: 11
Статус: Offline
Думал, дальше сам разберусь, вышло что нет. Теперь для другой ячейки мне нужно чтобы выдавалось минимальное число из этого диапазон но больше Х.
Напрмер если Х=8, то 10
если Х=35 от 50, если Х=245 то 500.
 
DV68Дата: Пятница, 28.10.2011, 16:33 | Сообщение # 35
Группа: Модераторы
Сообщений: 648
Статус: Offline
один из вариантов, но при поиске числа, имеющегося в массиве, выдаст следующее число:
Code
=ПРОСМОТР(C5;C3:G3;D3:H3)
 
kapitanДата: Пятница, 28.10.2011, 16:38 | Сообщение # 36
Группа: Проверенные
Сообщений: 11
Статус: Offline
Благодарю. Вот это познания!!! Снимаю шляпу
 
DV68Дата: Пятница, 28.10.2011, 16:44 | Сообщение # 37
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если при совпадении нужно это же число, то можно так:
Code
=ИНДЕКС(C3:H3;ПОИСКПОЗ(1;ЧАСТОТА(C5;C3:H3);0))
 
kapitanДата: Пятница, 28.10.2011, 17:03 | Сообщение # 38
Группа: Проверенные
Сообщений: 11
Статус: Offline
К хорошему привыкаешь быстро, уже разбираться неохота, если можно спросить.
Последний вопрос:
Как выбрать число из таблицы зная показатели по вертикали и горизонтали Например:

X 10 20 40 50
Y
50 15 18 20 30
100 20 25 30 40
300 25 30 50 60

Например известно, Х=20; Y=100, как вывести число 25
 
DV68Дата: Пятница, 28.10.2011, 17:39 | Сообщение # 39
Группа: Модераторы
Сообщений: 648
Статус: Offline
=ИНДЕКС(C4:F6;ПОИСКПОЗ(B8;C3:F3;0);ПОИСКПОЗ(B9;B4:B6;0))
 
kapitanДата: Пятница, 28.10.2011, 17:47 | Сообщение # 40
Группа: Проверенные
Сообщений: 11
Статус: Offline
Все, спасибо, у меня получилось
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Подскажите формулу или несколько формул "ЕСЛИ" или что то
Страница 2 из 2«12
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz