Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » разделить дату по столбцам
разделить дату по столбцам
БелославаДата: Вторник, 21.06.2011, 14:25 | Сообщение # 1
Группа: Пользователи
Сообщений: 4
Статус: Offline
Подскажите, пожалуйста, знающие люди!!!! Как можно разделить дату на 3 столбца: отдельно число, месяц и год.
 
Serge_007Дата: Вторник, 21.06.2011, 14:57 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Code
=ДЕНЬ(дата)

Code
=МЕСЯЦ(дата)

Code
=ГОД(дата)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
БелославаДата: Вторник, 21.06.2011, 15:34 | Сообщение # 3
Группа: Пользователи
Сообщений: 4
Статус: Offline
Спасибо огромное!!!! :) :) :)
 
БелославаДата: Вторник, 21.06.2011, 18:00 | Сообщение # 4
Группа: Пользователи
Сообщений: 4
Статус: Offline
Возник еще один вопросик....
как преобразовать № полученного месяца (по описанному выше методу) из числа в текст.
Пример:первоначальные данные - 25.06.1958; делим на столбцы, получаем - 25 6 1958
А хотелось бы вместо "6" получить "июня"
Это возможно???
 
DV68Дата: Вторник, 21.06.2011, 18:49 | Сообщение # 5
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (Белослава)
А хотелось бы вместо "6" получить "июня"
Это возможно???

Легко:
Code
=ТЕКСТ(A1;"[$-FC19]ММММ")


в А1 - дата
 
Serge_007Дата: Вторник, 21.06.2011, 19:38 | Сообщение # 6
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (Белослава)
хотелось бы вместо "6" получить "июня"


Именно для месяца, а не для даты можно так:
Code
=ВПР(МЕСЯЦ(А1);{1;"январь":2;"февраль":3;"март":4;"апрель":5;"май":6;"июнь":7;"июль":8;"август":9;"сентябрь":10;"октябрь":11;"ноябрь":12;"декабрь"};2;0)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
БелославаДата: Вторник, 21.06.2011, 20:15 | Сообщение # 7
Группа: Пользователи
Сообщений: 4
Статус: Offline
ОГО!!!!! век живи - век учись, дураком помрешь...... это я про себя

Еще раз Спасибо большое!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » разделить дату по столбцам
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz