Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Произвеcти выборку формулой (Произвеcти выборку формулой)
Произвеcти выборку формулой
alex_jobДата: Среда, 02.02.2011, 13:42 | Сообщение # 1
Группа: Пользователи
Сообщений: 8
Статус: Offline
Добрый день! Помогите пожалуйста "Произвеcти выборку формулой". Имеется массив данных в одном из столбцов номера магазинов в другом столбце дата открытия. Нужно чтобы формула при наборе номера магазина, показывала дату открытия. Я пробывал формулу индекс и поиск поз, но у меня вывечивает НД.
Прикрепления: 2522572.xls(41Kb)
 
Serge_007Дата: Среда, 02.02.2011, 15:22 | Сообщение # 2
Группа: Проверенные
Сообщений: 468
Статус: Offline
Здравствуйте.
В В1 выбирайте магазин в С1 - будет дата.

Code
=ВПР(B1;$B$3:$H$46;ЧИСЛСТОЛБ($B$3:$H$46);0)
Прикрепления: alex_job_2.xls(42Kb)


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
alex_jobДата: Среда, 02.02.2011, 16:02 | Сообщение # 3
Группа: Пользователи
Сообщений: 8
Статус: Offline
В B1 ввожу номер Пишет значение не неайдено
 
DV68Дата: Среда, 02.02.2011, 16:19 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (alex_job)
Я пробывал формулу индекс и поиск поз, но у меня вывечивает НД

Что-то я не нашел в Вашем файле ни одной формулы. Если в В1 ставим № магазина, то:
Code
=ИНДЕКС(N3:N46;поискпоз(B1;A3:A46;0))

Сергей Вам дал формулу, где надо вводить название и адрес магазина и даже для удобства сделал выпадающий список. Если нужен номер, то меняйте диапазон:

Code
=ВПР(B1;$A$3:$H$46;ЧИСЛСТОЛБ($A$3:$H$46);0)

или
Code
=ВПР(B1;A3:H46;8;0)
 
alex_jobДата: Среда, 02.02.2011, 16:21 | Сообщение # 5
Группа: Пользователи
Сообщений: 8
Статус: Offline
Огромное спасибо, понял Тема закрыта
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Произвеcти выборку формулой (Произвеcти выборку формулой)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz