Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Выборка данных и их автозамена из одной книги в другой
Выборка данных и их автозамена из одной книги в другой
ЧайкаДата: Понедельник, 31.01.2011, 20:04 | Сообщение # 1
Группа: Пользователи
Сообщений: 5
Статус: Offline
Господа! Помогите или дайте совет.
Задача в следующем: есть распечатка данных звонков сотрудников фирмы и есть база данных телефонных номеров клиентов, возможно ли следующее действие:
- Провести замену номеров телефонов в распечатке на имена клиентов из базы данных
- Что бы данная замена не действовала в других книгах
Помогите кто чем может!!!
 
DV68Дата: Вторник, 01.02.2011, 19:09 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Давайте небольшой пример Ваших данных в файле xls. Конфиденциальные замените на яблоки и апельсины).
 
ЧайкаДата: Вторник, 01.02.2011, 21:33 | Сообщение # 3
Группа: Пользователи
Сообщений: 5
Статус: Offline
Вот небольшой пример: надо заменить номера в файле Список звонков на фамилии из База.
Прикрепления: Desktop.rar(15Kb)
 
ЧайкаДата: Вторник, 01.02.2011, 21:35 | Сообщение # 4
Группа: Пользователи
Сообщений: 5
Статус: Offline
И Спасибо за внимание!
 
vladДата: Вторник, 01.02.2011, 22:18 | Сообщение # 5
Группа: Модераторы
Сообщений: 720
Статус: Offline
Номера на фамилии не заменить. idontnow Возможно вывести фамилии в соседних ячейках. Номера нужны как критерий отбора.
 
ЧайкаДата: Вторник, 01.02.2011, 22:26 | Сообщение # 6
Группа: Пользователи
Сообщений: 5
Статус: Offline
Понятно! Ну хоть что-то! Я уже попробовал следующий вариант: создал еще один лист под названием Baza, прописал формулу ну и вот что получилось:
Прикрепления: 2668155.xlsx(13Kb)
 
DV68Дата: Среда, 02.02.2011, 15:48 | Сообщение # 7
Группа: Модераторы
Сообщений: 648
Статус: Offline
Вы на правильном пути. Только, если объемы данных большие, вместо ВПР я бы посоветовал использовать связку
ИНДЕКС(...;ПОИСКПОЗ(...)). Пошустрее будет.
Code
=ЕСЛИ(C2="";"";ЕСЛИ(ЕНД(ПОИСКПОЗ(C2;Baza!A$2:A$110;0));"нет такого";ИНДЕКС(Baza!B$2:B$110;ПОИСКПОЗ(C2;Baza!A$2:A$110;0))))
 
ЧайкаДата: Среда, 02.02.2011, 18:53 | Сообщение # 8
Группа: Пользователи
Сообщений: 5
Статус: Offline
Спасибо, приму к сведению!! А возможно ли таким образом связать две книги???
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Выборка данных и их автозамена из одной книги в другой
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz