Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Хитрая задумка
Хитрая задумка
toxic2007Дата: Среда, 29.09.2010, 11:53 | Сообщение # 1
Группа: Пользователи
Сообщений: 7
Статус: Offline
Уважаемые! Подскажите пожалуйста как реализовать следующую хитрую задумку.
Каждый месяц в году будет добавляться число от 0 до 31, но фишка в том, что меня всегда будет интересовать сумма последних 24-х месяцев, т.е по простому это выглядит так =СУММ(B3:Y3), потом добавляется январь 2010г. СУММ(B3:Y3)+Z3 и минусуется январь 2008г. СУММ(B3:Y3)+Z3-B3, и что бы эта сумма попадала в фиолетовую ячейку к примеру. Таблица не будет заканчиваться на 2010 году. Буду очень признателен Вам, если поможете.
Прикрепления: new.xls(18Kb)
 
DV68Дата: Среда, 29.09.2010, 13:03 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Можно так (с августа 2008 по август 2010), в октябре будет с сентября 2008 по сентябрь 2010:
=СУММ(ИНДЕКС(3:3;ПОИСКПОЗ(ДАТА(ГОД(A1);МЕСЯЦ(A1)-25;1);2:2;0)):ИНДЕКС(3:3;ПОИСКПОЗ(ДАТА(ГОД(A1);МЕСЯЦ(A1)-1;1);2:2;0)))

обратите внимание на числа в строке 2

Прикрепления: new_otvet.xls(22Kb)
 
toxic2007Дата: Среда, 29.09.2010, 13:28 | Сообщение # 3
Группа: Пользователи
Сообщений: 7
Статус: Offline
Не совсем работает, если я в ячейку AG3 добавляю единицу, то сумма не должна измениться, а формула начинает дальше считать нарастающим итогом. И второй момент, ячейки в диапозоне =B3:H3 не задействованы
Прикрепления: _new_otvet.xls(28Kb)
 
DV68Дата: Среда, 29.09.2010, 14:38 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Quote (toxic2007)
Не совсем работает, если я в ячейку AG3 добавляю единицу, то сумма не должна измениться, а формула начинает дальше считать нарастающим итогом. ...

измените МЕСЯЦ(A1)-25 на МЕСЯЦ(A1)-24 в формуле, будет считать 24 месяца с сентября 2008 по август 2010 включительно. Желательно Вам самостоятельно разобраться в формуле, чтобы можно было по мелочам что-то менять.

Quote (toxic2007)
И второй момент, ячейки в диапозоне =B3:H3 не задействованы

а они что, должны участвовать в сложении? или нужна таки сумма за последние 24 месяца?


Сообщение отредактировал DIM5955 - Среда, 29.09.2010, 14:39
 
toxic2007Дата: Среда, 29.09.2010, 14:58 | Сообщение # 5
Группа: Пользователи
Сообщений: 7
Статус: Offline
Quote

а они что, должны участвовать в сложении? или нужна таки сумма за последние 24 месяца?

за последние 24 месяца "вообще", база будет вестись к примеру с 2005 года и до бесконечности, поэтому ячейки должны быть задействованы все, но сумма должна показываться только последних 24 месяцев
 
toxic2007Дата: Среда, 29.09.2010, 15:39 | Сообщение # 6
Группа: Пользователи
Сообщений: 7
Статус: Offline
Все отлично! Я разобрался, просто хотел проверить на перед как она считает, но сразу не получилось, оказывается там привязка к системной дате, при изменении даты в перед или наооборот назад, работоспособность проверена. Спасибо Вам большое!
 
toxic2007Дата: Четверг, 30.09.2010, 11:31 | Сообщение # 7
Группа: Пользователи
Сообщений: 7
Статус: Offline
Помогите, пожалуйста, усовершенствовать таблицу

1. Протянуть формулу вниз до бесконечности по все фиолетовым ячейкам (у меня не получается, нарастающим итогом меняется ячейка с датой), лучше объяснить как это сделать.
2. Задать условие для фиолетовых ячеек, если в диапазоне с месяцами, 6 раз подряд попадут нули, то фиолетовая ячейка закрашивается в красную.
3. Задать условие, если сумма последних 24 месяцев меньше, к примеру 25, то фиолетовая ячейка закрашивается в красную.

При много благодарен!!!

Прикрепления: NEW.xls(30Kb)
 
DV68Дата: Четверг, 30.09.2010, 13:00 | Сообщение # 8
Группа: Модераторы
Сообщений: 648
Статус: Offline
1 Надо в формуле закрепить необходимые строки значком $. (Почитайте про абсолютные и относительные ссылки).
2. Для условного форматирования формула: ?????????
3. В условном форматировании значение ячейки меньше 25.

Над вторым еще подумаю, мож кто другой ответит.

Прикрепления: NEW_otvet_2.xls(26Kb)
 
DV68Дата: Четверг, 30.09.2010, 14:10 | Сообщение # 9
Группа: Модераторы
Сообщений: 648
Статус: Offline
Советую отказаться от второго условия, формула получается очень массивная, повесит весь файл.
 
toxic2007Дата: Четверг, 30.09.2010, 14:40 | Сообщение # 10
Группа: Пользователи
Сообщений: 7
Статус: Offline
Я тоже так думаю))) Спасибо огромное!
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Хитрая задумка
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz