Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Сортировка по дате (Сортировка данных в зависимости от даты)
Сортировка по дате
MardanshaДата: Четверг, 08.04.2010, 23:20 | Сообщение # 1
Группа: Пользователи
Сообщений: 10
Статус: Offline
Приветствую.

Подскажите как сделать так, что бы данные суммировались автоматически в зависимости от месяца.
Не работающий пример прилагается.

Прикрепления: 9854809.xls(18Kb)
 
vladДата: Пятница, 09.04.2010, 00:45 | Сообщение # 2
Группа: Модераторы
Сообщений: 720
Статус: Offline
Можно так.
Прикрепления: 12.xls(26Kb)
 
DV68Дата: Пятница, 09.04.2010, 02:28 | Сообщение # 3
Группа: Модераторы
Сообщений: 648
Статус: Offline
Вариант:

=СУММПРОИЗВ((МЕСЯЦ($A$1:$A$13)=СТРОКА(A1))*$B$1:$B$13)



Сообщение отредактировал DIM5955 - Пятница, 09.04.2010, 02:30
 
DV68Дата: Пятница, 09.04.2010, 02:39 | Сообщение # 4
Группа: Модераторы
Сообщений: 648
Статус: Offline
Еще вариант:

=СУММ(ИНДЕКС((МЕСЯЦ(A$1:A$13)=СТРОКА(A1))*B$1:B$13;0))



Сообщение отредактировал DIM5955 - Пятница, 09.04.2010, 02:40
 
MardanshaДата: Четверг, 15.04.2010, 11:18 | Сообщение # 5
Группа: Пользователи
Сообщений: 10
Статус: Offline
Зур рахмат (по татарски "Большое спасибо")
Попробую.
 
MardanshaДата: Четверг, 15.04.2010, 13:17 | Сообщение # 6
Группа: Пользователи
Сообщений: 10
Статус: Offline
А как сделать что бы данные вписывались горизонтально?
 
DV68Дата: Четверг, 15.04.2010, 16:37 | Сообщение # 7
Группа: Модераторы
Сообщений: 648
Статус: Offline
Поменять СТРОКА на СТОЛБЕЦ:
Прикрепления: 9854809-otvet.xls(19Kb)
 
MardanshaДата: Четверг, 15.04.2010, 22:41 | Сообщение # 8
Группа: Пользователи
Сообщений: 10
Статус: Offline
))) many thanks!
 
art-leeДата: Вторник, 02.08.2011, 10:26 | Сообщение # 9
Группа: Пользователи
Сообщений: 1
Статус: Offline
Quote (DV68)
Поменять СТРОКА на СТОЛБЕЦ:
Прикрепления: 9854809-otvet.xls(19Kb)


подскажите пожалуйста, как в данной формуле: =СУММПРОИЗВ((МЕСЯЦ($A1:$A13)=СТОЛБЕЦ(A1))*$B1:$B13)
программа узнает что А1-это январь?
=СУММПРОИЗВ((МЕСЯЦ($A1:$A13)=СТОЛБЕЦ(B1))*$B1:$B13)
то что В1-это февраль и т.д.???
или что это за ячейки?
просто я пытаюсь сделать тоже самое в своем файле у меня пишет ЗНАЧ.
буду благодарен за ответ!
 
Serge_007Дата: Вторник, 02.08.2011, 14:12 | Сообщение # 10
Группа: Проверенные
Сообщений: 468
Статус: Offline
Quote (art-lee)
как в данной формуле: =СУММПРОИЗВ((МЕСЯЦ($A1:$A13)=СТОЛБЕЦ(A1))*$B1:$B13)
программа узнает что А1-это январь?
СТОЛБЕЦ(A1) возвращает значение 1 (столбец А - на листе первый по счёту), МЕСЯЦ($A1:$A13) возвращает номера месяцев дат, находящихся в диапазоне A1:A13 (1 1 1 1 12 2 2 2 2 2 3 3). Если 1=1, то возвращается значения диапазона B1:B13 (245 65 875 23 1267 987 235 265 98 45 145 75) и суммируются.


Бесплатная помощь: www.excelworld.ru
Платная помощь: serge_007.planetaexcel@mail.ru
Яндекс-деньги: 41001419691823
WMR: 126292472390
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Сортировка по дате (Сортировка данных в зависимости от даты)
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz