Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: DV68, Author 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Округление числа с условием
Округление числа с условием
kadanovatatyanaДата: Вторник, 16.09.2014, 16:58 | Сообщение # 1
Группа: Пользователи
Сообщений: 2
Статус: Offline
Помогите, пжл... Табличку с примером вкладываю. Нужно вес округлить в большую сторону, например 1,1 кг будет равен 2 кг. При этом Москва и Питер округляется только до целого числа, а все остальные города округляются сначала до 0,5 кг и весь остальной вес только целые числа.
Прикрепления: 3628380.xlsx(11Kb)


geva
 
DV68Дата: Среда, 17.09.2014, 14:30 | Сообщение # 2
Группа: Модераторы
Сообщений: 648
Статус: Offline
Если правильно понял, то можно так:
Код
=ОКРВВЕРХ(B2;0,5+((A2="Москва")+(A2="С-Петербург"))*0,5)
Прикрепления: 3628380_otv.xlsx(12Kb)
 
kadanovatatyanaДата: Среда, 17.09.2014, 15:53 | Сообщение # 3
Группа: Пользователи
Сообщений: 2
Статус: Offline
Да, спасибо, типо того... Только все города нужно до целого числа округлить. Единственное, что кроме целых чисел, есть еще 0,5 (это кроме Москвы и Питера), а после 0,5 также 1, 2, 3 и т.д. :bw:

Сама я составила вот такую штуковину:
=ЕСЛИ((A2="Москва")+(А2="С-Петербург");ОКРУГЛВВЕРХ(В2;1);ЕСЛИ(B2<=0,5;0,5;ОКРУГЛВВЕРХ(B2;1)))
Хотя результат не выходит, понимаю, где-то что-то неправильно ввела...


geva

Сообщение отредактировал kadanovatatyana - Среда, 17.09.2014, 17:13
 
Форум » ТЕМАТИЧЕСКИЕ » Excel - Готовые формулы » Округление числа с условием
Страница 1 из 11
Поиск:
  <script type="text/javascript">teasernet_blockid = 656993;teasernet_padid = 271069;</script><script type="text/javascript" src="http://bzlwe.com/07f6/bad6484c927/07.js"></script> 
Copyright MyCorp © 2017 Используются технологии uCoz